Skip to content

Commit

Permalink
dev-libs/libintl: Bump to versions 0.20.2 and 0.21
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/732148
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jul 27, 2020
1 parent 4fb8814 commit 407bfe9
Show file tree
Hide file tree
Showing 3 changed files with 162 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/libintl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST gettext-0.19.7.tar.gz 19235781 BLAKE2B 4c2cfcb0b21a66a9f8d2d57de7420e624a1235f97180ad5ac194a5eb629760a9cacc7f3966cdf893d7af86c1740d8bb2266c639ebe2664ea44f2c47a962a841a SHA512 7ba89074d3eddd0b4a5e2980e1ec74b53c49b7a04a1fa91c70c4bc11ce9c30415e4df9d79698148eaaed325fb4feb25a340a2e8e01fbe86b1a66b1376a4c9e3d
DIST gettext-0.19.8.1.tar.gz 19704011 BLAKE2B 17dc7aad338a26d71b818fea51e46a47dccf14744ee575ce86b591becaea402e36d64dc018e1a84113c356122ffef367cf2fa424e51ebc9720350040b4960091 SHA512 073042fa2dc48804c58e76f036130a669e19612c25427b0ab14d0b366b549a63751bf3af03bfd0745d7c4f72497a4b2aab26a3cc6de83189ce111679073878e1
DIST gettext-0.20.1.tar.gz 23267473 BLAKE2B 34e776b985c7db105f8029e0f3400aa645ff6843cd35f778d48450368a31218ddcf590fbc7fd2d10f716b63094d6a15bf40b358e8a6f498d450d2420e7e7a5f2 SHA512 af6d74986da285df0bdd59524bdf01bb12db448e5ea659dda3b60b660c4a9063c80e8c74cc8751334e065e98348ee0db0079e43c67d485a15e86ae236115fe06
DIST gettext-0.20.2.tar.gz 23717789 BLAKE2B f0db5eacc93501020f31d80e4b11df708d5ce1ae76f9c35587c830c064a4b712284df4645cedf054a41e66ab08d14d080c4fe1d316a108b997207b78148ed579 SHA512 50b0520230dba5da6e04e51b2317e073cacf1536d73ea88e4b5dc6cc5bd97cf2c9a279c3c3ada1067f39c8b3bb0b1ce8e0823cc1dd4c33f4f10860bdf787009d
DIST gettext-0.21.tar.gz 24181849 BLAKE2B 2eae99d0916b00b2af6fbc6bf7e309076519a10fea16cd49e7aa29fe8aec1ee7c784c6277281b764dc4abacf400cd3fe461129586303c8cd337db15c76cb4b87 SHA512 bbe590c5dd3580c75bf30ff768da99a88eb8d466ec1ac9eea20be4cab4357ecf72448e6b81b47425e39d50fa6320ba426632914d7898dfebb4f159abc39c31d1
80 changes: 80 additions & 0 deletions dev-libs/libintl/libintl-0.20.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Note: Keep version bumps in sync with sys-devel/gettext.

EAPI=7

MY_P="gettext-${PV}"

inherit multilib-minimal toolchain-funcs libtool usr-ldscript

DESCRIPTION="the GNU international library (split out of gettext)"
HOMEPAGE="https://www.gnu.org/software/gettext/"
SRC_URI="mirror://gnu/gettext/${MY_P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="static-libs +threads"

DEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
# Block C libraries known to provide libintl.
RDEPEND="${DEPEND}
!sys-libs/glibc
!sys-libs/musl
!<sys-devel/gettext-0.19.6-r1"

S="${WORKDIR}/${MY_P}/gettext-runtime"

src_prepare() {
default

# The libtool files are stored higher up, so make sure we run in the
# whole tree and not just the subdir we build.
elibtoolize "${WORKDIR}"
}

multilib_src_configure() {
local myconf=(
# Emacs support is now in a separate package.
--without-emacs
--without-lispdir
# Normally this controls nls behavior in general, but the libintl
# subdir is skipped unless this is explicitly set. ugh.
--enable-nls
# This magic flag enables libintl.
--with-included-gettext
# The gettext package provides this library.
--disable-c++
--disable-libasprintf
# No java until someone cares.
--disable-java

$(use_enable static-libs static)
$(use_enable threads)
)
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}

multilib_src_compile() {
# We only need things in the intl/ subdir.
emake -C intl
}

multilib_src_install() {
# We only need things in the intl/ subdir.
emake DESTDIR="${D}" install -C intl

gen_usr_ldscript -a intl
}

multilib_src_install_all() {
if ! use static-libs ; then
find "${ED}" -type f -name "*.la" -delete || die
fi

rm -r "${ED}"/usr/share/locale || die

dodoc AUTHORS ChangeLog NEWS README
}
80 changes: 80 additions & 0 deletions dev-libs/libintl/libintl-0.21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Note: Keep version bumps in sync with sys-devel/gettext.

EAPI=7

MY_P="gettext-${PV}"

inherit multilib-minimal toolchain-funcs libtool usr-ldscript

DESCRIPTION="the GNU international library (split out of gettext)"
HOMEPAGE="https://www.gnu.org/software/gettext/"
SRC_URI="mirror://gnu/gettext/${MY_P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="static-libs +threads"

DEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
# Block C libraries known to provide libintl.
RDEPEND="${DEPEND}
!sys-libs/glibc
!sys-libs/musl
!<sys-devel/gettext-0.19.6-r1"

S="${WORKDIR}/${MY_P}/gettext-runtime"

src_prepare() {
default

# The libtool files are stored higher up, so make sure we run in the
# whole tree and not just the subdir we build.
elibtoolize "${WORKDIR}"
}

multilib_src_configure() {
local myconf=(
# Emacs support is now in a separate package.
--without-emacs
--without-lispdir
# Normally this controls nls behavior in general, but the libintl
# subdir is skipped unless this is explicitly set. ugh.
--enable-nls
# This magic flag enables libintl.
--with-included-gettext
# The gettext package provides this library.
--disable-c++
--disable-libasprintf
# No java until someone cares.
--disable-java

$(use_enable static-libs static)
$(use_enable threads)
)
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}

multilib_src_compile() {
# We only need things in the intl/ subdir.
emake -C intl
}

multilib_src_install() {
# We only need things in the intl/ subdir.
emake DESTDIR="${D}" install -C intl

gen_usr_ldscript -a intl
}

multilib_src_install_all() {
if ! use static-libs ; then
find "${ED}" -type f -name "*.la" -delete || die
fi

rm -r "${ED}"/usr/share/locale || die

dodoc AUTHORS ChangeLog NEWS README
}

0 comments on commit 407bfe9

Please sign in to comment.