Skip to content

Commit

Permalink
dev-go/go-tools: version bump to 0_pre20160220
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
zmedico committed Feb 21, 2016
1 parent 4c10fc9 commit 4090eaa
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-go/go-tools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST go-favicon.ico 1150 SHA256 d76ca702a6d81e20ddd31c8c5a4368130e7c68d990600316
DIST go-tools-0_pre20150823.tar.gz 1633447 SHA256 12ac4c5e49134a7dcc9c2f3123d20562463d83360a6e1d2fc6ace5ec025a31ae SHA512 6d906bae8433182e7a105a46b92c4f64ac145196ccc72f8934376fc49e5d554182931745e92229c4571323a6eba9ce2f680b5add3844ecb593a194cbbc1b0b63 WHIRLPOOL acb3ac4e5abcc56a37bec461a7e4170e4a45ebd917ed9ca1dd016c92756a01b0ed0887e525bc17acd7a88a34fd5f9495a5ffa63f58a05d547e2fba17c4ff9a8e
DIST go-tools-0_pre20150902.tar.gz 1630401 SHA256 c5026af549199f62a374b705981cf0f04661497af0d69ee47d54e9992ee44c8f SHA512 437d5178ce5bf6c4d39ad638259e7c18150d2574dffb632003fa0b83a61a9103e666e562aecc6e8412d995e4b5ffacda6bc12b1cfbbea0b22a5ff680a0a7e3e1 WHIRLPOOL bfc7998c3c042059213975dc6864814edf497b5c6ee70c228925bcb7dd283efb4f49d7ac05383b8ae2d85ccc7fbd7663e3c2899bffe47e4e36195bd639bc61c7
DIST go-tools-0_pre20160121.tar.gz 1768660 SHA256 4f1d444643e06bc9da47655e6532d71cdd4dfe3167352d93fd48a8e31bec5a60 SHA512 ca4b213a6f398f9bb61a81784fb6dcb4a82994e2d7a95134fc5203ce0f65848d192b2d7c8975a59199db873942c23562866a5607347e060ac0af370d72e067e2 WHIRLPOOL fa4f0006211cb52eca9cba015235a07d7d640681864a62ed065454efceb789694ea3a6d0099adec910bee075153e56e1323cb7e6f4d9a7426d2b8e40474a715e
DIST go-tools-0_pre20160220.tar.gz 1827046 SHA256 395190b159e918204f67dee0b8f08f55d14cf59b83aa79cdb69c75de71c8d99a SHA512 95c9deb9b01b2f294818fcc847e457ab313d5831a839bf9cfeb1a00a0efd833de3fdfd3ecfe7ecfa2dd236ffcf963e73205d7b5b25fa41ab51c7601dc632bce1 WHIRLPOOL 48737d871487e693040b448e799d89f8461e6dc60ee12cc21fe874d9897b9721397986aa947af3bcbc2e514422e3c27147a5d2fe21b4fb7593c91e1fb267e424
111 changes: 111 additions & 0 deletions dev-go/go-tools/go-tools-0_pre20160220.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EGO_PN="golang.org/x/tools/..."

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
EGIT_COMMIT="ee8cb08bfe4453a27a4bd7c86a917800d339c5ac"
ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
inherit golang-vcs-snapshot
fi
inherit golang-build

DESCRIPTION="Go Tools"
HOMEPAGE="https://godoc.org/golang.org/x/tools"
SRC_URI="${ARCHIVE_URI}
http://golang.org/favicon.ico -> go-favicon.ico"
LICENSE="BSD"
SLOT="0/${PVR}"
IUSE=""
DEPEND="dev-go/go-net:=
>=dev-lang/go-1.5"
RDEPEND="!<dev-lang/go-1.5"

src_prepare() {
local go_src="${EGO_PN%/...}"
# disable broken tests
rm src/${go_src}/cmd/bundle/main_test.go || die
sed -e 's:TestWeb(:_\0:' \
-e 's:TestWebIndex(:_\0:' \
-i src/${go_src}/cmd/godoc/godoc_test.go || die
sed -e 's:TestGuru(:_\0:' \
-i src/${go_src}/cmd/guru/guru_test.go || die
sed -e 's:TestVet(:_\0:' \
-e 's:TestDivergentPackagesExamples(:_\0:' \
-e 's:TestIncompleteExamples(:_\0:' \
-i src/${go_src}/cmd/vet/vet_test.go || die
sed -e 's:TestImport(:_\0:' \
-i src/${go_src}/go/gcimporter/gcimporter_test.go || die
sed -e 's:TestImportStdLib(:_\0:' \
-i src/${go_src}/go/gcimporter15/gcimporter_test.go || die
sed -e 's:TestImportStdLib(:_\0:' \
-i src/${go_src}/go/importer/import_test.go || die
sed -e 's:TestStdlib(:_\0:' \
-i src/${go_src}/go/loader/stdlib_test.go || die
sed -e 's:TestStdlib(:_\0:' \
-i src/${go_src}/go/ssa/stdlib_test.go || die
sed -e 's:TestGorootTest(:_\0:' \
-e 's:TestFoo(:_\0:' \
-e 's:TestTestmainPackage(:_\0:' \
-i src/${go_src}/go/ssa/interp/interp_test.go || die
sed -e 's:TestBar(:_\0:' \
-e 's:TestFoo(:_\0:' \
-i src/${go_src}/go/ssa/interp/testdata/a_test.go || die
sed -e 's:TestCheck(:_\0:' \
-i src/${go_src}/go/types/check_test.go || die
sed -e 's:TestStdlib(:_\0:' \
-e 's:TestStdFixed(:_\0:' \
-e 's:TestStdKen(:_\0:' \
-i src/${go_src}/go/types/stdlib_test.go || die
sed -e 's:TestRepoRootForImportPath(:_\0:' \
-i src/${go_src}/go/vcs/vcs_test.go || die
sed -e 's:TestFindImportInternal(:_\0:' \
-i src/${go_src}/imports/fix_test.go || die

# Add favicon to the godoc web interface (bug 551030)
cp "${DISTDIR}"/go-favicon.ico "src/${go_src}/godoc/static/favicon.ico" ||
die
sed -e 's:"example.html",:\0\n\t"favicon.ico",:' \
-i src/${go_src}/godoc/static/makestatic.go || die
sed -e 's:<link type="text/css":<link rel="icon" type="image/png" href="/lib/godoc/favicon.ico">\n\0:' \
-i src/${go_src}/godoc/static/godoc.html || die
}

src_compile() {
# Generate static.go with favicon included
pushd src/golang.org/x/tools/godoc/static >/dev/null || die
go run makestatic.go || die
popd >/dev/null

golang-build_src_compile
}

src_test() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
mkdir -p "${T}/goroot/test" || die
GOROOT="${T}/goroot" golang-build_src_test
rm -rf "${T}/goroot"
}

src_install() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
cp -sR "$(get_golibdir_gopath)" "${T}/gopath" || die

GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:${T}/gopath" go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
golang_install_pkgs

# bug 558818: install binaries in $GOROOT/bin to avoid file collisions
exeinto "$(go env GOROOT)/bin"
doexe bin/* "${T}/goroot/bin/godoc"
dodir /usr/bin
ln "${ED}$(go env GOROOT)/bin/godoc" "${ED}usr/bin/godoc" || die

rm "${D}"$(go env GOROOT)/bin/{cover,vet} || die
}

0 comments on commit 4090eaa

Please sign in to comment.