Skip to content

Commit

Permalink
app-emulation/free42: 2.2.1
Browse files Browse the repository at this point in the history
Build binary version
Update ebuild

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed May 23, 2019
1 parent 01adaba commit 40b7275
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/free42/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST free42-nologo-2.0.20.tgz 7390214 BLAKE2B 306f3378bcbb44fa7982c5d9c29bfbea62e915ca50ca5e5216f46fbf483f110a1288d4800991a74622a042517496ff8dd94c3fa3249e8bb4181957e6b23d5ea3 SHA512 9b540fbc50df2f94b135b5e778354f330df77a54ef2ad99b257b5b91d1e3e8d1241e8a834522fc46fe33571ea2695ad8889b427dbcf653870672e89cd56d60f5
DIST free42-nologo-2.2.1.tgz 7398286 BLAKE2B 041c9672305b712efab8e7d5eb73bc0bd159b5fd61e9ecf39d5ce691aff045be4a6a4c635c0948e610e51832db64b388bdd001eb57aad41724e27dff4cf95a0a SHA512 2ed735ff161ea14ca5be97131b69065410faa699ed05d3eb94abbb9653c694d83fc4e45ea2bcf0c2a7894f89e731ee7839105dc1d58d6a6326047c9bd55da5d7
9 changes: 9 additions & 0 deletions app-emulation/free42/files/free42-2.0.10-fix-makefile.patch
Original file line number Diff line number Diff line change
Expand Up @@ -56,3 +56,12 @@ diff -Nuar a/gtk/Makefile b/gtk/Makefile

$(SRCS) skin2cc.cc keymap2cc.cc skin2cc.conf: symlinks

@@ -107,7 +111,7 @@

symlinks:
for fn in `cd ../common; /bin/ls`; do ln -s ../common/$$fn; done
- sh ./build-intel-lib.sh
+ +sh ./build-intel-lib.sh
ln -s IntelRDFPMathLib20U1/TESTS/readtest.c
touch symlinks

53 changes: 53 additions & 0 deletions app-emulation/free42/free42-2.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

MY_PV="${PN}-nologo-${PV}"

DESCRIPTION="An HP-42S Calculator Simulator"
HOMEPAGE="http://thomasokken.com/free42/"
SRC_URI="http://thomasokken.com/free42/upstream/${MY_PV}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+alsa"

DEPEND="dev-libs/atk
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/pango
alsa? ( media-libs/alsa-lib )"

RDEPEND="${DEPEND}
x11-libs/libX11
x11-libs/libXmu"

DOCS=( CREDITS HISTORY README )
S="${WORKDIR}/${MY_PV}"

PATCHES=(
"${FILESDIR}/${PN}-2.0.10-fix-makefile.patch"
"${FILESDIR}/${PN}-2.0.10-fix-build-intel-lib.patch"
)

src_prepare() {
default
}

src_compile() {
local myconf
use alsa && myconf="AUDIO_ALSA=yes"
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
emake -C gtk clean
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
}

src_install() {
default
dobin gtk/free42bin gtk/free42dec
}

0 comments on commit 40b7275

Please sign in to comment.