Skip to content

Commit

Permalink
app-crypt/gnupg: Minor changes to 2.1.16
Browse files Browse the repository at this point in the history
For now tools subdir always needs to be built, even though the use flag controls
whether some of the resulting binaries are installed or not, as e.g
gpg-connect-agent and gpg-wks-client is expected to be installed unconditionally.

Given that tools subdir is a cheap build, this doesn't constitute much of an
actual issue, but upstream is notified.

Gentoo-Bug: 600208

Add patch to mitigate test failure due to overlong socket path.

Package-Manager: portage-2.3.2
  • Loading branch information
krifisk committed Nov 22, 2016
1 parent 42cea86 commit 40c193d
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From cf3778631f87ad03274ac94dcae7c7fbbd036913 Mon Sep 17 00:00:00 2001
From: Kristian Fiskerstrand <[email protected]>
Date: Tue, 22 Nov 2016 10:07:33 +0100
Subject: [PATCH] gpgscm: Use shorter socket path lengts to improve test
reliability

--
As socket lengths are normally restricted to 108 characters
(UNIX_PATH_MAX variable in /usr/include/linux/un.h), using 42 characters
by default easily results in errors.
---
tests/gpgscm/tests.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/gpgscm/tests.scm b/tests/gpgscm/tests.scm
index 72afa99..039ea86 100644
--- a/tests/gpgscm/tests.scm
+++ b/tests/gpgscm/tests.scm
@@ -268,9 +268,9 @@
(define (mkdtemp . components)
(_mkdtemp (if (null? components)
(path-join (getenv "TMP")
- (string-append "gpgscm-" (get-isotime) "-"
+ (string-append "gscm"
(basename-suffix *scriptname* ".scm")
- "-XXXXXX"))
+ "XXXXXX"))
(apply path-join components))))

(macro (with-temporary-working-directory form)
--
2.7.3

5 changes: 3 additions & 2 deletions app-crypt/gnupg/gnupg-2.1.16.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"

SLOT="0"
IUSE="bzip2 doc +gnutls ldap nls readline selinux +smartcard tofu +tools usb wks-server"
IUSE="bzip2 doc +gnutls ldap nls readline selinux +smartcard tofu tools usb wks-server"

COMMON_DEPEND_LIBS="
>=dev-libs/npth-1.2
Expand Down Expand Up @@ -50,6 +50,7 @@ S="${WORKDIR}/${MY_P}"

src_prepare() {
default
epatch "${FILESDIR}/${PN}-2.1.16-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
epatch_user
}

Expand Down Expand Up @@ -88,7 +89,7 @@ src_configure() {
$(use_enable nls) \
$(use_with readline) \
$(use_enable tofu) \
$(use_enable tools) \
--enable-tools \
$(use_enable wks-server wks-tools) \
CC_FOR_BUILD="$(tc-getBUILD_CC)"
}
Expand Down

0 comments on commit 40c193d

Please sign in to comment.