Skip to content

Commit

Permalink
dev-util/buildbot-worker: Version bump to 1.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
dol-sen committed Jul 26, 2018
1 parent a7a3d82 commit 40e19a4
Show file tree
Hide file tree
Showing 2 changed files with 134 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/buildbot-worker/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST buildbot-worker-0.9.12.tar.gz 101655 BLAKE2B a73f98ec56bd3ad6d19ad0b9dfa015869fd6115789a7ddcecdebdac8707850715c677ee248668f73035ea5656665973634829f2f97e3e75fe8e1515cb0838b88 SHA512 c2e86bd8818eddc2849626a0c7642169bc91fa2cc1d531977736e53c4ad3c87c3f0cb17d7b9acd137e783ae822f558a19f4668e3cd37e90a8435157485bd1d57
DIST buildbot-worker-1.1.2.tar.gz 103013 BLAKE2B b44593b71e61fee4037911759fa4f686aaabf5ef4be9efaecd539e88c5fc2ed2059d8dd8d6d1c4b3ba57d3563f79aaa404176529622003070c136803c90beb10 SHA512 3dd3da7e87d667307fca264d91af4671f76c3aad93a0512ae5777bb2e3972efe349968cf72fa17b99e45f2d7cec1ec16b1180c48d296e2702c9548bf858951a7
DIST buildbot-worker-1.3.0.tar.gz 103765 BLAKE2B a5f06ad6b87442292f9fe0c7935f791d2fdb450db09c9614324f8230d0bec408380a7b1637dc32806259c4de7699b164f20f76d959232a82253f7134749531d7 SHA512 5e59aab6cecf8dd932df0e8063c69fda5613b76a46df63479ff554085275d4a19fb1b5142034bd4245423e99f3e46d45e765b10c3c74a9f28b92b70119fab9e2
133 changes: 133 additions & 0 deletions dev-util/buildbot-worker/buildbot-worker-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,133 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"

[[ ${PV} == *9999 ]] && inherit git-r3
inherit readme.gentoo-r1 user distutils-r1

DESCRIPTION="BuildBot Worker (slave) Daemon"
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-worker/"

MY_V="${PV/_p/.post}"
MY_P="${PN}-${MY_V}"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
if [[ ${PV} == *9999 ]]; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE="test"

RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
!<dev-util/buildbot-0.9.7
"
DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/${MY_P}"
[[ ${PV} == *9999 ]] && S=${S}/worker

pkg_setup() {
enewuser buildbot

DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
to support starting buildbot_worker through Gentoo's init system. To use this,
execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
Set up your build worker following the documentation, make sure the
resulting directories are owned by the \"buildbot\" user and point
\"${ROOT}etc/conf.d/buildbot_worker.myinstance\" at the right location.
The scripts can run as a different user if desired."
}

python_test() {
distutils_install_for_testing

esetup.py test || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all

doman docs/buildbot-worker.1

newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker

dodir /var/lib/buildbot_worker
cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_print_elog

if [[ -n ${REPLACING_VERSIONS} ]]; then
ewarn
ewarn "Starting with buildbot-worker-0.9.10-r1, more than one instance of a buildbot_worker"
ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot_worker configuration file"
ewarn "is now the common base directory for all instances. If you are migrating from an older"
ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
ewarn " rc-update add buildbot_worker.myinstance default"
ewarn " /etc/init.d/buildbot_worker.myinstance start"
ewarn "Systems using systemd can do the following:"
ewarn " systemctl enable [email protected]"
ewarn " systemctl enable buildbot_worker.target"
ewarn " systemctl start buildbot_worker.target"
fi
}

pkg_config() {
local buildworker_path="/var/lib/buildbot_worker"
local log_path="/var/log/buildbot_worker"

einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
einfo "Press Control-C to abort."

einfo "Enter the name for the new instance: "
read instance_name
[[ -z "${instance_name}" ]] && die "Invalid instance name"

local instance_path="${buildworker_path}/${instance_name}"
local instance_log_path="${log_path}/${instance_name}"

if [[ -e "${instance_path}" ]]; then
eerror "The instance with the specified name already exists:"
eerror "${instance_path}"
die "Instance already exists"
fi

if [[ ! -d "${instance_path}" ]]; then
mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
fi
chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
|| die "Moving sample configuration failed"
ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
|| die "Unable to create link to init file"

if [[ ! -d "${instance_log_path}" ]]; then
mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
fi
ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
|| die "Unable to create link to log file"

einfo "Successfully created a buildbot_worker instance at ${instance_path}."
einfo "To change the default settings edit the buildbot.tac file in this directory."
}

0 comments on commit 40e19a4

Please sign in to comment.