Skip to content

Commit

Permalink
app-doc/doxygen: apply llvm patches, fix subslot
Browse files Browse the repository at this point in the history
 - apply llvm patches, thanks to Stephen Newell for the patch.
 - add missing subslot operator

Closes: https://bugs.gentoo.org/666692
Closes: https://bugs.gentoo.org/657556
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Oct 2, 2018
1 parent 499eae6 commit 4126e1d
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 2 deletions.
5 changes: 3 additions & 2 deletions app-doc/doxygen/doxygen-1.8.14-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -30,7 +30,7 @@ RDEPEND="app-text/ghostscript-gpl
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( dev-libs/xapian )
doxysearch? ( dev-libs/xapian:= )
latex? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
Expand Down Expand Up @@ -59,6 +59,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.14-llvm7.patch" #666692
)

DOCS=( LANGUAGE.HOWTO README.md )
Expand Down
25 changes: 25 additions & 0 deletions app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5c55efae..1ad32b2e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -262,7 +262,7 @@ if (use_libclang)
add_definitions(${LLVM_DEFINITIONS})
llvm_map_components_to_libnames(llvm_libs support core option)
target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
+ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs})
endif()

target_link_libraries(doxygen
diff --git a/src/clangparser.cpp b/src/clangparser.cpp
index 77151d6e..2ea15ee2 100644
--- a/src/clangparser.cpp
+++ b/src/clangparser.cpp
@@ -4,6 +4,7 @@

#if USE_LIBCLANG
#include <clang-c/Index.h>
+#include "clang/Tooling/CompilationDatabase.h"
#include "clang/Tooling/Tooling.h"
#include <qfileinfo.h>
#include <stdlib.h>

0 comments on commit 4126e1d

Please sign in to comment.