forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-doc/doxygen: apply llvm patches, fix subslot
- apply llvm patches, thanks to Stephen Newell for the patch. - add missing subslot operator Closes: https://bugs.gentoo.org/666692 Closes: https://bugs.gentoo.org/657556 Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Matthias Maier <[email protected]>
- Loading branch information
Showing
2 changed files
with
28 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
index 5c55efae..1ad32b2e 100644 | ||
--- a/src/CMakeLists.txt | ||
+++ b/src/CMakeLists.txt | ||
@@ -262,7 +262,7 @@ if (use_libclang) | ||
add_definitions(${LLVM_DEFINITIONS}) | ||
llvm_map_components_to_libnames(llvm_libs support core option) | ||
target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS}) | ||
- set(CLANG_LIBS libclang clangTooling ${llvm_libs}) | ||
+ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs}) | ||
endif() | ||
|
||
target_link_libraries(doxygen | ||
diff --git a/src/clangparser.cpp b/src/clangparser.cpp | ||
index 77151d6e..2ea15ee2 100644 | ||
--- a/src/clangparser.cpp | ||
+++ b/src/clangparser.cpp | ||
@@ -4,6 +4,7 @@ | ||
|
||
#if USE_LIBCLANG | ||
#include <clang-c/Index.h> | ||
+#include "clang/Tooling/CompilationDatabase.h" | ||
#include "clang/Tooling/Tooling.h" | ||
#include <qfileinfo.h> | ||
#include <stdlib.h> |