Skip to content

Commit

Permalink
gui-apps/foot: add 1.13.1
Browse files Browse the repository at this point in the history
Signed-off-by: Arsen Arsenović <[email protected]>
Closes: gentoo#27092
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
ArsenArsen authored and thesamesam committed Aug 31, 2022
1 parent 1027d54 commit 41285ab
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/foot/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST foot-1.12.1.tar.gz 484702 BLAKE2B 5f3ed5923dfe2e3d110da298d4abefb331c15bb0f3db3135a4e8d481b528b3f8287fc5d8516e9d3a34b8084f6364edae93dee496d9192fe610d2c17733277451 SHA512 553f404b074f4372fb8cfb050f0378d1cbe1620ea8afe2e279523df3006eefd0b0ed24addca33de10cfc8109e5aaec66beccbd5f30e032bb9f2bd9b81ac798cb
DIST foot-1.13.0.tar.gz 495396 BLAKE2B 9acad754d47754d6161fd4024b7f6a8336cd5e6faa1112bdf390c79ecbd52f74b187544667ca8517618f05324af76da66f0320e86e8b0e178a0f63c556992edf SHA512 ac7c8dc967c897f81f8eda8b0c5de17896015698ac266bc9ce898d3fdb41d0dd96762f28f433d8a31f768e0505e4c89151ef10484407f66865ea6322fa1b6705
DIST foot-1.13.1.tar.gz 496955 BLAKE2B 48155439cd11123320908e67a968304903f96a550b62a3aa0c8d5e2053c3b6b2d49e4f4dcbe547b3296fbd05b19385d941ba668975ca3fb3a47a9627ef3d87f8 SHA512 f8b0e0d801452ecae914e2535041a65c105ea132a6841b659ac28ebfbfb06f06210466fe05553349a18c50227d7f21677298ff9692c3e9062df37b47aa40f3e1
72 changes: 72 additions & 0 deletions gui-apps/foot/foot-1.13.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson xdg systemd

DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
HOMEPAGE="https://codeberg.org/dnkl/foot"
SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="+grapheme-clustering"

COMMON_DEPEND="
dev-libs/wayland
media-libs/fcft
media-libs/fontconfig
x11-libs/libxkbcommon
x11-libs/pixman
grapheme-clustering? (
dev-libs/libutf8proc:=
media-libs/fcft[harfbuzz]
)
"
DEPEND="
${COMMON_DEPEND}
dev-libs/tllist
dev-libs/wayland-protocols
"
RDEPEND="
${COMMON_DEPEND}
|| (
>=sys-libs/ncurses-6.3[-minimal]
~gui-apps/foot-terminfo-${PV}
)
"
BDEPEND="
app-text/scdoc
dev-util/wayland-scanner
"

src_prepare() {
default
# disable the systemd dep, we install the unit file manually
sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
}

src_configure() {
local emesonargs=(
$(meson_feature grapheme-clustering)
-Dthemes=true
-Dime=true
-Dterminfo=disabled
)
meson_src_configure

sed 's|@bindir@|/usr/bin|g' "${S}/"/[email protected] > [email protected]
}

src_install() {
local DOCS=( CHANGELOG.md README.md LICENSE )
meson_src_install

# foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
# we handle this via DOCS and dodoc instead.
rm -r "${ED}/usr/share/doc/${PN}" || die
systemd_douserunit [email protected] "${S}"/[email protected]
}

0 comments on commit 41285ab

Please sign in to comment.