Skip to content

Commit

Permalink
games-emulation/mgba: Bump to version 0.8.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 4, 2020
1 parent 19f09ad commit 4128e83
Show file tree
Hide file tree
Showing 2 changed files with 122 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mgba/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mgba-0.7.3.tar.gz 11228977 BLAKE2B 2b70bb97470558e6c10391b782f0f80e0466b2f16df07971ed378801d359157692ce56c61f4432640ed679d43dc2445a1ea45b3402c1b488fb534213d8594271 SHA512 131f850699f17a7496f7428b85b50f38b99acec4c87d5d28ba4e3af94f095a1b6d177ea731838b2971362b46c52accef9cbec98433ecfaccc080371092c7d789
DIST mgba-0.8.1.tar.gz 11893993 BLAKE2B 0b5db35927111a23defaf33ea67b00613c01302940db8bfe6c21aab4ec39bdb089ddbd6238ca7ccd35010724b058f78cee3ca3cbc6d7fbe0047f25a152b208fa SHA512 7873bde6a74e8a1509a3b5bba602da1c747ca1eff72adcf11f7b2572298d94766570fea0b920cb28c8b63a7d8237a15876b9feb9169edbf331b2d72f340734e2
DIST mgba-0.8.2.tar.gz 12014352 BLAKE2B 5a22d186b2732ba66698ac3fe47cd6ce841ca36ba856e5344948cf14a73aa9368658d94f0e6fb4fd78ae0a454c6d534182ecce221b3b24d62dde511c0aaa02a2 SHA512 181abab9e94964e2027cb039ded6128af1364e1442c418b8703263c9e0c5befeb7aca4d925fb44f3e25e8711a2cc22b198ea00483c42aea3b1c7ba077223d426
DIST mgba-0.8.3.tar.gz 12013512 BLAKE2B 750c1bcb5cfe30e6e0965a16dbdb91b4dbf9f6b1068b7a9c343932c9b7b08c2b6aef4f7f4f38ee5d4e3ebb73d0f55222c78654be777858f36bd452b5f732e76c SHA512 8154cec08f9ab4fc7cedc7988ed8ee320ad076666e2958b4fa0620801398081aa4808b61dbafd2e7c4b9ff0edfbb761e013fd7117206e81478a6c09ef91e2a5a
121 changes: 121 additions & 0 deletions games-emulation/mgba/mgba-0.8.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,121 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake desktop xdg

DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mgba-emu/mgba.git"
else
MY_PV="${PV/_beta/-b}"
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
[[ "${PV}" == *_beta* ]] || \
KEYWORDS="~amd64 ~arm64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="MPL-2.0"
SLOT="0"
IUSE="debug discord elf ffmpeg opengl qt5 +sdl sqlite"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"

RDEPEND="
media-libs/libpng:0=
sys-libs/zlib[minizip]
elf? ( dev-libs/elfutils )
ffmpeg? ( media-video/ffmpeg:= )
opengl? ( virtual/opengl )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtwidgets:5
opengl? ( dev-qt/qtopengl:5 )
)
sdl? ( media-libs/libsdl2[X,sound,joystick,video,opengl?] )
sqlite? ( dev-db/sqlite:3 )
"
DEPEND="${RDEPEND}"

src_prepare() {
xdg_environment_reset
cmake_src_prepare

# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
rm -r src/third-party/${pkg} || die
done
}

src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DBUILD_GL="$(usex opengl)"
-DBUILD_PYTHON=OFF
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"
-DBUILD_SHARED=ON
# test suite fails to build (>=0.6.0)
-DBUILD_SUITE=OFF
-DBUILD_TEST=OFF
-DM_CORE_GB=ON
-DM_CORE_GBA=ON
-DUSE_DEBUGGERS="$(usex debug)"
-DUSE_DISCORD_RPC="$(usex discord)"
-DUSE_EDITLINE="$(usex debug)"
-DUSE_ELF="$(usex elf)"
-DUSE_EPOXY=OFF
-DUSE_FFMPEG="$(usex ffmpeg)"
-DUSE_GDB_STUB="$(usex debug)"
-DUSE_LIBZIP=OFF
-DUSE_LZMA=OFF
-DUSE_MINIZIP=ON
-DUSE_PNG=ON
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
cmake_src_configure
}

src_compile() {
cmake_src_compile
}

src_install() {
if use qt5 ; then
dobin ../${P}_build/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
newicon -s ${size} res/${PN}-${size}.png ${PN}.png
done
fi
if use sdl ; then
doman doc/${PN}.6
newbin ../${P}_build/sdl/${PN} ${PN}-sdl
fi

dolib.so ../${P}_build/lib${PN}.so*
}

pkg_preinst() {
if use qt5 ; then
xdg_pkg_preinst
fi
}

pkg_postinst() {
if use qt5 ; then
xdg_pkg_postinst
fi
}

pkg_postrm() {
if use qt5 ; then
xdg_pkg_postrm
fi
}

0 comments on commit 4128e83

Please sign in to comment.