Skip to content

Commit

Permalink
net-im/skypeforlinux: version bump to 5.1.0.1
Browse files Browse the repository at this point in the history
Closes:gentoo#4361
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
karolgrudzinski authored and Amynka committed Apr 17, 2017
1 parent 9754224 commit 414e240
Show file tree
Hide file tree
Showing 2 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/skypeforlinux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST skypeforlinux_5.0.0.5-1.x86_64.rpm 67525460 SHA256 afd90e232849e90508f7ce06c765d850e9353f8074443d9f1d99fc0c53789cef SHA512 fe09406d57cc02910078c4ede54986753a671cd7b31fa6733f7c111cecf0cc574b13f08980470a32b9921b77ab1fc2cac24faef5fcd2110e8e579003d6e035f0 WHIRLPOOL 87cf34808494a4b46788e9f8539b5b435a59bfa583456bd8c0c6c17f890e3ff6b44a168d25c588cdaf98431db0b3261f423c021cf9aa85b92bbed772c91b6376
DIST skypeforlinux_5.1.0.1-1.x86_64.rpm 67541387 SHA256 ca05f35ed845e63bccb86256b7bd1de06bc312fd0c07f027995121bc807f6bac SHA512 ea9caf93fb6b115c9bf2972bd36d479f1ed365ed2462d6b0fc312d8566df30dbb7273de26f3f6240042bf3ddd49865c3509bf11b884eae938344456327cf3697 WHIRLPOOL 611272ca0c9f1c76510f7a2ae6411214f203aa9c2855271359d38f2f64c6e7ccdcd827afa45453f0658ae1f10889b5c7716ff5eec29a344035f55ad46b3f3051
106 changes: 106 additions & 0 deletions net-im/skypeforlinux/skypeforlinux-5.1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils pax-utils rpm

DESCRIPTION="P2P Internet Telephony (VoiceIP) client"
HOMEPAGE="https://www.skype.com/"
SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"

LICENSE="Skype-TOS no-source-code"
SLOT="0"
KEYWORDS="~amd64"
IUSE="pax_kernel"

S="${WORKDIR}"
QA_PREBUILT=opt/skypeforlinux/skypeforlinux
RESTRICT="mirror bindist strip" #299368

RDEPEND="dev-libs/atk
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
gnome-base/libgnome-keyring
media-libs/alsa-lib
media-libs/fontconfig:1.0
media-libs/freetype:2
net-print/cups
sys-apps/dbus
sys-devel/gcc[cxx]
sys-libs/glibc
virtual/ttf-fonts
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/pango"

src_unpack() {
rpm_src_unpack ${A}
}

src_prepare() {
default
sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
-i usr/bin/skypeforlinux || die
sed -e "s!^Exec=.*!Exec=${EPREFIX}/opt/bin/skypeforlinux!" \
-e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
-i usr/share/applications/skypeforlinux.desktop || die
}

src_install() {
insinto /opt/skypeforlinux/locales
doins usr/share/skypeforlinux/locales/*.pak

insinto /opt/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release
doins usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node

insinto /opt/skypeforlinux/resources
doins usr/share/skypeforlinux/resources/*.asar

insinto /opt/skypeforlinux
doins usr/share/skypeforlinux/*.pak
doins usr/share/skypeforlinux/*.bin
doins usr/share/skypeforlinux/*.dat
doins usr/share/skypeforlinux/version
exeinto /opt/skypeforlinux
doexe usr/share/skypeforlinux/*.so
doexe usr/share/skypeforlinux/skypeforlinux

into /opt
dobin usr/bin/skypeforlinux

dodoc -r usr/share/doc/skypeforlinux/.

doicon usr/share/pixmaps/skypeforlinux.png

local res
for res in 16 32 256 512; do
newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
done

domenu usr/share/applications/skypeforlinux.desktop

if use pax_kernel; then
pax-mark -Cm "${ED%/}"/opt/skypeforlinux/skypeforlinux
eqawarn "You have set USE=pax_kernel meaning that you intend to run"
eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
eqawarn "you suspect that ${PN} is being broken by this modification,"
eqawarn "please open a bug."
fi
}

0 comments on commit 414e240

Please sign in to comment.