Skip to content

Commit

Permalink
app-admin/ansible: 2.8.3 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Jul 26, 2019
1 parent b154163 commit 418b54f
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ansible-2.7.11.tar.gz 11855636 BLAKE2B 3de8fa1287655f778b1d9036bf78a91387cf
DIST ansible-2.7.12.tar.gz 11860944 BLAKE2B 52cc79a88bbff9dc009ead8ab9f9d299420ae060e211aab23fe3bbef8c8229cd9e526dc3df518a4285cc17c1448ab4892cc3059d70bfef2fd332a44c72b57019 SHA512 0ab68af8239f6d4d2a13bd38a09fe6f3c700231e7c83df0af77c70ea62faebd0d45e1ff316963c6c72931608d49a79b98e8d3ddc6f4c8b826aabe87dc71cc6f9
DIST ansible-2.8.1.tar.gz 14299403 BLAKE2B defbe8fa8db7ab3325cf57df3bdfe901f53544b4c1b6460cefbfa9393acfe2a0e104f99468ad8e907d90d33842563bd7ab666d30f64572fd146c7ce46ff77048 SHA512 08be80584edfe28f11fe750735ade117deaf3a7c98fe15fb2fa0e3a5ed0c3f98cd126b60386e51d15ce275e8f1fc3eda0177bb56e0823b2f2b7702cc0e35be92
DIST ansible-2.8.2.tar.gz 14328267 BLAKE2B 9548af73914b68374f71ab83e5a68e86e75b8ccf86066831699b147091d067a3f1e0b59d94b22b42151d90779f6d3bb39856a3d205862c933aec6bbe76824e22 SHA512 02cd8fd214f61041914abeebf2395f16acf370e110bdef0181689f604f06504902f9a05a2413877a31680528af539f078e2cd7b7f2eebe2389c9aa441b063305
DIST ansible-2.8.3.tar.gz 14343746 BLAKE2B 3859d88d8462f7109ab23c169b4a91c7a03940b5a8aaff4bfc7ab430fb533898a44221dee18f481612abe1cce1270211a34c2bc1dc7603d89adeb11e50d2b242 SHA512 cee2c663577155269c4d762816590200224e87979411dc7486f5840783f23aaa688577a3f75e272c4875af30397bb383d11eaa7d122d5f304388d5b45ffb9b6f
68 changes: 68 additions & 0 deletions app-admin/ansible/ansible-2.8.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{5,6,7} )

inherit distutils-r1 eutils

DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://ansible.com/"
SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
IUSE="doc test"
RESTRICT="test"

RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/netaddr[${PYTHON_USEDEP}]
net-misc/sshpass
virtual/ssh
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
dev-vcs/git
)"

python_compile_all() {
if use doc; then
cd docs/docsite || die
export CPUS=4
emake -f Makefile.sphinx html
fi
}

python_prepare_all() {
rm -fv MANIFEST.in || die
distutils-r1_python_prepare_all
}

python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}

python_install_all() {
use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all

dodoc -r examples
}

0 comments on commit 418b54f

Please sign in to comment.