Skip to content

Commit

Permalink
app-emulation/sen: Bump to 0.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Nelo-T. Wallus <[email protected]>
Closes: gentoo#11428
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
ntnn authored and Lars Wendler committed Mar 20, 2019
1 parent 496d7b5 commit 41d171b
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/sen/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST sen-0.5.1.tar.gz 70930 BLAKE2B 93758076d014a36996ece021f1de2f3ece749453d32554fe79ffec0ab1101bf4cc5c11d80934817fa5b10d73b811e738c87ce8e745a642507ec8406ad2eb59fa SHA512 0faf2c12e6361d3b4e9d093e0830867976a1fbd03cadc7a527c88460244532a8b636d8d4b732bb0c7f4041a0bb0819d20caabe62327b5edbf731b4eb8a4898a6
DIST sen-0.6.0.tar.gz 55113 BLAKE2B 5f6affbea94005c0adc9ac544d40d94cd9a9eca930b979c19174d21d73fdd887d21802a5241c02ba212a45c4a7873f22c7372aeb69955e1f97e444ef74d91929 SHA512 5573a0d6da5ae395e947bf34c54313e4e3a0251dc1868c52bbfe9ad11463397da83a0c9ac3f1912da2e6f49341c84d40dcab900d41b4a32ebac44d1dde3ac82b
DIST sen-0.6.1.tar.gz 55357 BLAKE2B 0d58f0ea11eeff29161925018425c918b3260c754d1b658e2ebd3c88e0c371feb0f1815af61979206bee529c369a90ace895d25e645ef0d76c563abd8b74c943 SHA512 2f1cadf745ca7e12d3e92534e76984072b9678055b9911f76b1a6d3cbd43266ad1eeb4d5e7bb8742db91c4da4aef684fa644c33de6fa2494c37688e9747e0efa
37 changes: 37 additions & 0 deletions app-emulation/sen/sen-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit distutils-r1

DESCRIPTION="Terminal User Interface for docker engine"
HOMEPAGE="https://github.com/TomasTomecek/sen"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
dev-python/urwidtrees[${PYTHON_USEDEP}]
dev-python/docker-py[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/flexmock[${PYTHON_USEDEP}]
)
"

python_install_all() {
distutils-r1_python_install_all
dodoc -r docs
}

python_test() {
pytest -vv tests || die "pytest failed"
}

0 comments on commit 41d171b

Please sign in to comment.