Skip to content

Commit

Permalink
net-misc/dhcpcd: version bump to 6.11.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
williamh committed May 9, 2016
1 parent 37dad17 commit 420e5f3
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/dhcpcd/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST dhcpcd-6.10.0.tar.xz 179804 SHA256 ab56af9b2e86913c55a965cb0f835e87749df783
DIST dhcpcd-6.10.1.tar.xz 180112 SHA256 284abf8c3be0580bbac5eaca95359346ab0d78d4072317b6ce87cc68f2e8ae7b SHA512 f323c155cff47f21dde181c216408b79f10e6ed923aa3d1f3482feff47a1e88e02193ec82f831da4ef63d3703ca1837715c36a47cf3f5d09f117f6eb53bfcf67 WHIRLPOOL 805e8a1b4dad400825197dae7918a2172093d152986d5d97f4d1993f2c27cf3fbe097a5dc4f7a5292e98676b5d7fad6079ed64e4bffabeb7ccf9d91f4db80de9
DIST dhcpcd-6.10.2.tar.xz 184512 SHA256 64a0ff84ba7f1e820b2ccfe08980b3b73e96bb072274b21de523f1da83a94e09 SHA512 66e472b32373328fb18723d7efa9f200befb35762449a26a81d4c137eb17aae1d86bce59cc057dfb328e83061d7747a8c6facac2f0304750acfb4c634e896a65 WHIRLPOOL e92e64b36c26d651b8cd9ddc4c6902e351afe28c71a16a3f6bd069d1414eebf85791abb8eee3a6272134e5fec73f0ac4c0225c8b20ca2be07f2ac210b134bf7f
DIST dhcpcd-6.10.3.tar.xz 185520 SHA256 b586c1f770373f83e3f574c683c66bea217a6d6c89b8e91dbdb6f75aa654c8d5 SHA512 6ebcb720909f4d167d064d5e8ed961c331470762e89f4e5c145f048424ef170ffc218e9a9dcc94e3a8dce6ccc147710ec2ef17627a708918203858f3dcdca43d WHIRLPOOL 4c9844de4b6e69a761c7a5a9c34da7f97e906a379b837ccfe647f1fab5e648193298744a8eded6f46379c056cb8fcb8148af1f0e5e95d5726529a3cc2686b27f
DIST dhcpcd-6.11.0.tar.xz 187580 SHA256 31c2cd327657f11c427fe5044f74c5b942e70450fa43ceabf4b25f3fd4999959 SHA512 ee46f28b046752e80839c229e074cb87aea93695c1347ba852a026828a34b47f66990c9ce863f7de02ad81cc922c0ae000ab8fbb23ed9f2d1f97b720020db166 WHIRLPOOL 6950d95493baaf2c16343590f6c89fcf471de50c5423030607b1a26144c86636b40fb693ce87cd4d13e433f0423ff48449b7db37f7e1266038ee2b6268116ec5
115 changes: 115 additions & 0 deletions net-misc/dhcpcd/dhcpcd-6.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

if [[ ${PV} == "9999" ]]; then
FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
MY_P="${MY_P/_rc/-rc}"
SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi

inherit eutils systemd toolchain-funcs

DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"

COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"

if [[ ${PV} == "9999" ]]; then
DEPEND+=" dev-vcs/fossil"

src_unpack()
{
local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
local repo=${distdir}/fossil/${PN}.fossil

addwrite "${distdir}"

if [[ -e "${repo}" ]]; then
fossil pull "${FOSSIL_URI}" -R "${repo}" || die
else
mkdir -p "${distdir}/fossil" || die
fossil clone "${FOSSIL_URI}" "${repo}" || die
fi

mkdir -p "${S}" || die
cd "${S}" || die
fossil open "${repo}" || die
}
fi

src_configure()
{
local dev hooks rundir
use udev || dev="--without-dev --without-udev"
hooks="--with-hook=ntp.conf"
use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
use kernel_linux && rundir="--rundir=${EPREFIX}/run"
econf \
--prefix="${EPREFIX}" \
--libexecdir="${EPREFIX}/lib/dhcpcd" \
--dbdir="${EPREFIX}/var/lib/dhcpcd" \
--localstatedir="${EPREFIX}/var" \
${rundir} \
$(use_enable embedded) \
$(use_enable ipv6) \
${dev} \
CC="$(tc-getCC)" \
${hooks}
}

src_install()
{
default
newinitd "${FILESDIR}"/${PN}.initd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
}

pkg_postinst()
{
# Upgrade the duid file to the new format if needed
local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
local new_duid="${ROOT}"/etc/dhcpcd.duid
if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
fi

# Move the duid to /etc, a more sensible location
if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
cp -p "${old_duid}" "${new_duid}"
fi

if [ -z "$REPLACING_VERSIONS" ]; then
elog
elog "dhcpcd has zeroconf support active by default."
elog "This means it will always obtain an IP address even if no"
elog "DHCP server can be contacted, which will break any existing"
elog "failover support you may have configured in your net configuration."
elog "This behaviour can be controlled with the noipv4ll configuration"
elog "file option or the -L command line switch."
elog "See the dhcpcd and dhcpcd.conf man pages for more details."

elog
elog "Dhcpcd has duid enabled by default, and this may cause issues"
elog "with some dhcp servers. For more information, see"
elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
fi

if ! has_version net-dns/bind-tools; then
elog
elog "If you activate the lookup-hostname hook to look up your hostname"
elog "using the dns, you need to install net-dns/bind-tools."
fi
}

0 comments on commit 420e5f3

Please sign in to comment.