Skip to content

Commit

Permalink
media-gfx/feh: version bump to 3.2.1
Browse files Browse the repository at this point in the history
Signed-off-by: Tim Harder <[email protected]>
  • Loading branch information
radhermit committed Jul 27, 2019
1 parent 9864c3b commit 42128fb
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/feh/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST feh-3.1.1.tar.bz2 2109534 BLAKE2B ea02ab09791ef61a9ac5db84b5a0f69ddc76f994343660cf4072a41769a59ddd2936e0f047eeed26be0b3676711b1e440c0483325e6bb621205788ebe13c1fca SHA512 cbdf6e36831a750a6bdb9f1a5735c814662b5274d9c453392de88b98926b539cc54e2041fc0cd2a393762f14ec24b81435de6d506d9efc1ee4c7d80105aa6243
DIST feh-3.1.3.tar.bz2 2110285 BLAKE2B ee42b766eccf7e4661a47bd6c748b2e0cc6345fb9c08de425b0f4ef87c7fb383dd20140fb2c8b2fc540b70a6c01bb612b48aa76fc1f47a117f2503257bf3b403 SHA512 dc4960706e4134bbe6c34036a9c9b7cd98eb8935e13e2354504664a1599d4af193c6b977433a40c7e3638b2b3e2928960e0c755b04f7c48076ef15445f792583
DIST feh-3.2.1.tar.bz2 2112281 BLAKE2B 2918d2714f0557e1b67284709bce22c5e14d8f7f545ca33c16ec7928273edf18c9be48a685c3e9a032170bf2b7e572a4b78664f37b2a16c5ae5829b3cc55ca76 SHA512 11a136990f7d02409501f10553659c64ad5d18d4bfaa4e5cfdeb7a2f53ffdb8bd9b8347796c65e75c49615ac4c12bc81bf3a58325f778cb5e0c1608181d7b53a
DIST feh-3.2.tar.bz2 2111743 BLAKE2B 2fd9838845bb86cc17d99650ac595c2b9f573be30d6ea86512a37a2f0439b10d6fe0b6bc028b81d03219530db2c0c58b1e6642834c32a621b191a310d53c7499 SHA512 f87d07edb9aa098a6c71b37306c42fdfe2b9cdb8cafcd72dd04f82b5a79da47c4e55979a0a8365fe22681f857215120009c84cde34b6f36e599522a2c4af6f70
73 changes: 73 additions & 0 deletions media-gfx/feh/feh-3.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit toolchain-funcs gnome2-utils xdg-utils

DESCRIPTION="A fast, lightweight imageviewer using imlib2"
HOMEPAGE="https://feh.finalrewind.org/"
SRC_URI="https://feh.finalrewind.org/${P}.tar.bz2"

LICENSE="feh"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
IUSE="debug curl exif test xinerama"

COMMON_DEPEND="media-libs/imlib2[X]
>=media-libs/libpng-1.2:0=
x11-libs/libX11
curl? ( net-misc/curl )
exif? ( media-libs/libexif )
xinerama? ( x11-libs/libXinerama )"
RDEPEND="${COMMON_DEPEND}
virtual/jpeg:0"
DEPEND="${COMMON_DEPEND}
x11-base/xorg-proto
x11-libs/libXt
test? (
>=dev-lang/perl-5.10
dev-perl/Test-Command
media-libs/imlib2[gif,jpeg,png]
)"

PATCHES=( "${FILESDIR}"/${PN}-3.2-debug-cflags.patch )

pkg_setup() {
use_feh() { usex $1 1 0; }

fehopts=(
DESTDIR="${D}"
PREFIX="${EPREFIX}"/usr
doc_dir='${main_dir}'/share/doc/${PF}
example_dir='${main_dir}'/share/doc/${PF}/examples
curl=$(use_feh curl)
debug=$(use_feh debug)
xinerama=$(use_feh xinerama)
exif=$(use_feh exif)
)
}

src_compile() {
tc-export CC
emake "${fehopts[@]}"
}

src_install() {
emake "${fehopts[@]}" install
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

0 comments on commit 42128fb

Please sign in to comment.