Skip to content

Commit

Permalink
sys-kernel/gentoo-kernel-bin: bump to 5.4.64 for arm64
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Sep 10, 2020
1 parent 862799f commit 4231aa0
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/gentoo-kernel-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@ DIST gentoo-kernel-5.4.63-1.amd64.xpak 61958828 BLAKE2B 93f253c9523af74c3f42cc0d
DIST gentoo-kernel-5.4.63-1.arm64.xpak 57973091 BLAKE2B c68b023a7ba1ca295ff7115aa991b7a6f329c5dc6e8865b5cb46fb803bfe14b202aaa6ee0499a42353bf860309ffef57f2ee82d08b336765cae8388c34b4d7e1 SHA512 3121af01c82fb65992d9ddd5b81453fc6ab98ae64d749167a00eeae23e888410a967f196a92c0dd7de5a5bcf6f8ddb6214d6e8e6174a0da80fb28f65c0cb3480
DIST gentoo-kernel-5.4.63-1.x86.xpak 53725189 BLAKE2B 14c87985ebcc975321187483af9eddf8185da6ea0e967c604ad78f9d144dac24fac97704aa5b9a0f532549ccdb226cd00be5684519c135a90ef53db14264a18a SHA512 0cc28e5c50c1b898958a423e05bc1c0cb21e7ce333e4061c3344f9f9f6a615d915031eeb70cc5a36957d6fad0f05af5c436b35ee946393c71e6ed903b6b5d111
DIST gentoo-kernel-5.4.64-1.amd64.xpak 61493792 BLAKE2B 86a133920417723c458f946a22f04a704e4099abb280edec0d63f24ba982cc788af6c1081b044a76e71baeb81fef6de3353bf76d70d471a6c1afb21b5664cc8a SHA512 88e4630741416f144b1c69dba87aa3826914692603193b3c30a6eeb7ba94653bf77c8c017c4c20d82f83790e9b79556d87acc0c6392571a343d5b584665394cf
DIST gentoo-kernel-5.4.64-1.arm64.xpak 56477814 BLAKE2B abf9e68ec92b4cb3ad283c447ce8de26c3ea71660e82467da5dcca7450a1831044ab8cc888796b40b040e119f1f89a71789cd9c1020076db3d4209826035b06d SHA512 344225e57ff6ef188834ff82db2bb9c0d2da01a2b9087e91b55b1a658471ca5c45ed5b805249dd9113f6877f4cc56df866241d642dfbdc85f4ce59c4c1a7dffc
DIST gentoo-kernel-5.4.64-1.x86.xpak 53360544 BLAKE2B 0e67661699d063fe05a41ba15a25355c4395817a7c0f069159a38b3fbab7c9a696e7f9cf3ac905a9641f19439e9e7ca19a45748462fb89d522e56522bda3c55d SHA512 2da7eb14b81600f01057bcb9929f0632448de56b6959c8286039ec526090b6dbed3755cce78840b4a7db43e3b9d6e1abeb58a1726561bd204293f6f1ea9b8530
DIST gentoo-kernel-5.7.17-1.amd64.xpak 63476985 BLAKE2B 1a31855979a309c7bb4565208aa92dcac9d4fcf0714ea224c2a909b534ca65bac2778f6c2cee24cb5dbcfd825bc896b52cb14eb37cc36aedffadcc0217a32269 SHA512 4071bb9eb192da7823834365b8d6817dd043c256ff0803eb70a35278aa92b63a66fa1c8d86b2c91d90fceb7c7b4fb1ac41b347457d6ccda78e02c6e0f123c044
DIST gentoo-kernel-5.7.17-1.arm64.xpak 59769706 BLAKE2B e7f3180e3d4373a7923250b8fe12141c0138e04f81d08b014386270defcc25517028ef404163c5d81097c72d6605cd5a6b4f1ad6df15a0f77d13daebb6045268 SHA512 59b33b487c170bad68de3527506c3a13a1edd232de40281cfac463fd8641222c0e86c4aef3b47127746a54dde94456a7b21fb150ca66674f1efadaf5c5db7d34
Expand Down
57 changes: 57 additions & 0 deletions sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.64-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-install

MY_P=${P/-bin/}-1
DESCRIPTION="Pre-built Linux kernel with genpatches"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+="
amd64? (
https://dev.gentoo.org/~mgorny/binpkg/amd64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.amd64.xpak
)
arm64? (
https://dev.gentoo.org/~sam/binpkg/arm64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.arm64.xpak
)
x86? (
https://dev.gentoo.org/~mgorny/binpkg/x86/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak
-> ${MY_P}.x86.xpak
)"
S=${WORKDIR}

LICENSE="GPL-2"
KEYWORDS="~arm64"

RDEPEND="
!sys-kernel/gentoo-kernel:${SLOT}
!sys-kernel/vanilla-kernel:${SLOT}
!sys-kernel/vanilla-kernel-bin:${SLOT}"

QA_PREBUILT='*'

pkg_pretend() {
ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch"
ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."

kernel-install_pkg_pretend
}

src_unpack() {
ebegin "Unpacking ${MY_P}.${ARCH}.xpak"
tar -x < <(xz -c -d --single-stream "${DISTDIR}/${MY_P}.${ARCH}.xpak")
eend ${?} || die "Unpacking ${MY_P} failed"
}

src_test() {
kernel-install_test "${PV}" \
"${WORKDIR}/usr/src/linux-${PV}/$(kernel-install_get_image_path)" \
"lib/modules/${PV}"
}

src_install() {
mv * "${ED}" || die
}

0 comments on commit 4231aa0

Please sign in to comment.