forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-kernel/gentoo-kernel-bin: bump to 5.4.64 for arm64
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
862799f
commit 4231aa0
Showing
2 changed files
with
58 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
57 changes: 57 additions & 0 deletions
57
sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.64-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
# Copyright 2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kernel-install | ||
|
||
MY_P=${P/-bin/}-1 | ||
DESCRIPTION="Pre-built Linux kernel with genpatches" | ||
HOMEPAGE="https://www.kernel.org/" | ||
SRC_URI+=" | ||
amd64? ( | ||
https://dev.gentoo.org/~mgorny/binpkg/amd64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak | ||
-> ${MY_P}.amd64.xpak | ||
) | ||
arm64? ( | ||
https://dev.gentoo.org/~sam/binpkg/arm64/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak | ||
-> ${MY_P}.arm64.xpak | ||
) | ||
x86? ( | ||
https://dev.gentoo.org/~mgorny/binpkg/x86/kernel/sys-kernel/gentoo-kernel/${MY_P}.xpak | ||
-> ${MY_P}.x86.xpak | ||
)" | ||
S=${WORKDIR} | ||
|
||
LICENSE="GPL-2" | ||
KEYWORDS="~arm64" | ||
|
||
RDEPEND=" | ||
!sys-kernel/gentoo-kernel:${SLOT} | ||
!sys-kernel/vanilla-kernel:${SLOT} | ||
!sys-kernel/vanilla-kernel-bin:${SLOT}" | ||
|
||
QA_PREBUILT='*' | ||
|
||
pkg_pretend() { | ||
ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch" | ||
ewarn "Linux configs to Fedora. Please keep a backup kernel just in case." | ||
|
||
kernel-install_pkg_pretend | ||
} | ||
|
||
src_unpack() { | ||
ebegin "Unpacking ${MY_P}.${ARCH}.xpak" | ||
tar -x < <(xz -c -d --single-stream "${DISTDIR}/${MY_P}.${ARCH}.xpak") | ||
eend ${?} || die "Unpacking ${MY_P} failed" | ||
} | ||
|
||
src_test() { | ||
kernel-install_test "${PV}" \ | ||
"${WORKDIR}/usr/src/linux-${PV}/$(kernel-install_get_image_path)" \ | ||
"lib/modules/${PV}" | ||
} | ||
|
||
src_install() { | ||
mv * "${ED}" || die | ||
} |