Skip to content

Commit

Permalink
app-office/ledger: add 3.2.0 with py3.7, py3.8 support
Browse files Browse the repository at this point in the history
Add Python 3.7 & 3.8 support
Use external utf8cpp library
Add bash-completion support
Remove "emacs" USE flag

Closes: https://bugs.gentoo.org/689132
Bug: https://bugs.gentoo.org/721478
Closes: https://bugs.gentoo.org/692316
Signed-off-by: Gleb Nemshilov <[email protected]>
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: gentoo#15680
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
Gleb Nemshilov authored and a17r committed May 24, 2020
1 parent 4d93c54 commit 4273258
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/ledger/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ledger-3.1.2.tar.gz 801112 BLAKE2B 71b907a83fe10857d17de746c0d124572859c9eca237130ebbfa5b730406470a5d31025736e80516feaac7daf14a4edb8b644ed72a0827f9714ac9cb2b79c0fb SHA512 445d9a9c70aa3e59718f8fb75e4110c73f2f476436149fdd456b5fe7b9cee9333c09647080049989599dfac491e5bdd0d143717e58e15989db0fcaad4e5a958d
DIST ledger-3.2.0.tar.gz 790404 BLAKE2B 081ca5d857238aecbeae5a0ba3267864442a8c1772a71b1894f5a9fb33173f9a0bd488ad4db3844fce8172268e516ebb92ba0556ced6e67b2a089fbb5adfde36 SHA512 580f4f39d7c3cd2bd1d05bcc36b127cfb311219f39fe50dbf23f582f73dd986729d4b5fa76bfd89cd5db9bfdfcdd5dca5b9d6b24766650040e45b881726e65ea
115 changes: 115 additions & 0 deletions app-office/ledger/ledger-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8} )

inherit bash-completion-r1 check-reqs cmake python-single-r1

DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
HOMEPAGE="https://www.ledger-cli.org/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="debug doc python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="test"

CHECKREQS_MEMORY=8G

RDEPEND="
dev-libs/boost:=[python?]
dev-libs/gmp:0=
dev-libs/mpfr:0=
python? (
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_USEDEP}]
dev-python/cheetah3:=[${PYTHON_USEDEP}]
')
${PYTHON_DEPS}
)
"
DEPEND="
${RDEPEND}
dev-libs/utfcpp
doc? (
sys-apps/texinfo
virtual/texi2dvi
dev-texlive/texlive-fontsrecommended
)
"

pkg_pretend() {
if use python; then
check-reqs_pkg_pretend
fi
}

pkg_setup() {
if use python; then
check-reqs_pkg_setup
python-single-r1_pkg_setup
fi
}

src_prepare() {
cmake_src_prepare

# Want to type "info ledger" not "info ledger3"
sed -i -e 's/ledger3/ledger/g' \
doc/ledger3.texi \
doc/CMakeLists.txt \
test/CheckTexinfo.py \
tools/cleanup.sh \
tools/gendocs.sh \
tools/prepare-commit-msg \
tools/spellcheck.sh \
|| die "Failed to update info file name in file contents"

mv doc/ledger{3,}.texi || die "Failed to rename info file name"

rm -r lib/utfcpp || die
rm cmake/FindPython.cmake || die
rm -r cmake/FindPython || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_DOCS="$(usex doc)"
-DBUILD_WEB_DOCS="$(usex doc)"
-DUSE_PYTHON="$(usex python)"
-DPython_EXECUTABLE="${PYTHON}"
-DPython_INCLUDE_DIR="$(python_get_includedir)"
-DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
-DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON
-DBUILD_DEBUG="$(usex debug)"
-DUTFCPP_PATH="${ESYSROOT}/usr/include/utf8cpp"
)

cmake_src_configure
}

src_compile() {
cmake_src_compile

use doc && cmake_src_compile doc
}

src_install() {
cmake_src_install

newbashcomp contrib/${PN}-completion.bash ${PN}
}

pkg_postinst() {
elog
elog "Since version 3, vim support is released separately."
elog "See https://github.com/ledger/vim-ledger"
elog
elog "For Emacs mode, emerge app-emacs/ledger-mode"
}

# rainy day TODO:
# - IUSE test

0 comments on commit 4273258

Please sign in to comment.