Skip to content

Commit

Permalink
dev-libs/libnsfb: bump to version 0.2.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Philipp Ammann <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
trilean authored and juippis committed Dec 4, 2019
1 parent 8e3c012 commit 42ad54b
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libnsfb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libnsfb-0.2.0-src.tar.gz 82322 BLAKE2B d805478728015663b4bf9c8de018bda33dcd84a7ace7246c450a7c31cc3358f834ade21ac1df9f0ca0e4dcea1138369cc3cd9ac468ebb484cce139d4bc89441e SHA512 b90eca76c8dcb22e554e13b5bea4268e5c9fc6e4711bafa5acbed92cc83513c3a3965208b3956de250fb3013cc3db6a33922ded471fa7a24bde97f748d2212c5
DIST libnsfb-0.2.1-src.tar.gz 82357 BLAKE2B 2904b8890fd1ce3f6eb8d327db09c7b38146d5d16499beecbe56efd762e33d6ee9da3394ed7923ad43a89fa41e45602ea4af2710dbf2f232b42a038ee90abdcc SHA512 f8965aeaab0d8e7c2676bac56ae67bdf6ef651ae84c62e01aeee888807f1edd7d65542cb14027a8f1a207155a1cc54ded9112a42bf9e7a8836956bba38d365ed
50 changes: 50 additions & 0 deletions dev-libs/libnsfb/libnsfb-0.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="framebuffer abstraction library, written in C"
HOMEPAGE="http://www.netsurf-browser.org/projects/libnsfb/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE="sdl test vnc wayland xcb"

RDEPEND="sdl? ( >=media-libs/libsdl-1.2.15-r4 )
vnc? ( >=net-libs/libvncserver-0.9.9-r2 )
wayland? ( >=dev-libs/wayland-1.0.6 )
xcb? (
>=x11-libs/libxcb-1.9.1
>=x11-libs/xcb-util-0.3.9-r1
>=x11-libs/xcb-util-image-0.3.9-r1
>=x11-libs/xcb-util-keysyms-0.3.9-r1
)"
BDEPEND="
dev-util/netsurf-buildsystem"

PATCHES=( "${FILESDIR}"/${PN}-0.1.0-autodetect.patch )

DOCS=( usage )

_emake() {
source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared \
WITH_VNC=$(usex vnc) \
WITH_SDL=$(usex sdl) \
WITH_XCB=$(usex xcb) \
WITH_WLD=$(usex wayland) \
$@
}

src_compile() {
_emake
}

src_install() {
_emake DESTDIR="${ED}" install
}

0 comments on commit 42ad54b

Please sign in to comment.