forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pyasn1: version bump to 0.4.2
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST pyasn1-0.2.3.tar.gz 100099 BLAKE2B 32e6fa765fc5c217f66ca5618acc132c96fd8adc3649e5323696ac8dcd2cc11fcbd0a362e53575465da79feb422452b9f964e4972ab7f581571e5cbfc14a8945 SHA512 c55b95c1995f2fc36ec28f35837ca456a2fac06e90edc6491a3335ae949e4eacbbeb14f6289a17e994b49d4dc60870bba3e79344c44496d5547c38ab1ef183ab | ||
DIST pyasn1-0.3.7.tar.gz 117643 BLAKE2B 66e4987a63139c7af06d6bcdb125ef6f0f46ea5885bbbefae6c76252bd96296abf71a59f6ddc6f196ef78077a62649963c4d9419546f631d93e723dca30bf9b2 SHA512 85735ecb5b83979e51c9f663e2e0dcfbc317ba7e22474d78998f97c40a3487fd06ade9a259d1a4a8de5f4e70e5521a060af127799b92931ceb26abd384ec5807 | ||
DIST pyasn1-0.4.2.tar.gz 118404 BLAKE2B b96135b10eb9b79ac02b21d35df19ee1078a51586eb37832004a1891db0cce305fe3fb65c34f4b05fd1c854f1d708aa59b3e85908df39d54ebb051a2f021ca60 SHA512 30e7cdfd2f7b182081f951bd94169a300a577f95fbfcb4ddb6dc288617b2776265018d246ae0adb649650ee94aab9122a428313d7a61559f97ed7f02b9670709 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="ASN.1 library for Python" | ||
HOMEPAGE="http://snmplabs.com/pyasn1/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos" | ||
IUSE="doc" | ||
|
||
RDEPEND="" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )" | ||
|
||
python_test() { | ||
esetup.py test || die "Tests fail with ${EPYTHON}" | ||
} | ||
|
||
src_compile() { | ||
if use doc; then | ||
python_setup | ||
esetup.py build_sphinx | ||
fi | ||
distutils-r1_src_compile | ||
} | ||
|
||
src_install() { | ||
local HTML_DOCS | ||
use doc && HTML_DOCS=( build/sphinx/html/. ) | ||
|
||
distutils-r1_src_install | ||
} |