Skip to content

Commit

Permalink
dev-libs/d0_blind_id: Bump to version 1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed May 18, 2017
1 parent 7e014d0 commit 42c298f
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/d0_blind_id/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST d0_blind_id-0.5.tar.gz 344460 SHA256 9a223609df9c5d92c63047fc320ae64034ccd8815624da84806e0916c9f4ac75 SHA512 0a7735269a41108f191c4143b52eff2179889d94239be5be0c2406c6ed789b68e2d545250f9964e97f8c86a0653296bacdbe9b8d9db89a79ca6922d7c1a90162 WHIRLPOOL f87a624283df549d852c2a859f60e9cfd51ef85fa6233d254dd3f6c4bef95ffb9e2aff95584791ff4bad01fb3b557903aa223654607e61ab742d5fb1ae217594
DIST d0_blind_id-1.0.tar.gz 49110 SHA256 e9edcc55af1b322a5e51832f4a95b456a368d527b34ff31ebe88340728eca5a1 SHA512 dbee0bec44a008a6843ec367211e4cdfa25f6c4577b48d942d19301d5ff885d4fde8d40ea304a114d349d8e90283a50854afb2fb322bf19640842ded025849f2 WHIRLPOOL 15e10c6dae4982f16f20c97e541a012947232d1a6881ea7151d20759510d7ed9fa1f38a94469f90e736d375532a3781700eb25f0617d315fc4d94f6d6d21d57e
51 changes: 51 additions & 0 deletions dev-libs/d0_blind_id/d0_blind_id-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
SRC_URI="https://github.com/divVerent/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"

RDEPEND="dev-libs/gmp:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"

DOCS=( d0_blind_id.txt )

src_prepare() {
default

# fix out-of-source build
sed -i \
-e 's, d0_rijndael.c, "$srcdir/d0_rijndael.c",' \
configure.ac || die

eautoreconf
}

src_configure() {
local myeconfargs=(
--enable-rijndael
--without-openssl
--without-tfm
--without-tommath
$(use_enable static-libs static)
)
econf "${myeconfargs[@]}"
}

src_install() {
default

if ! use static-libs ; then
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
fi
}

0 comments on commit 42c298f

Please sign in to comment.