Skip to content

Commit

Permalink
dev-db/freetds: new version 1.00.53.
Browse files Browse the repository at this point in the history
Gentoo-Bug: 585592

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
orlitzky committed Aug 12, 2017
1 parent ddfa04b commit 42c6544
Show file tree
Hide file tree
Showing 3 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/freetds/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST freetds-0.91.tar.gz 2136329 SHA256 6a8148bd803aebceac6862b0dead1c5d9659f7e1038993abfe0ce8febb322465 SHA512 4dadafe49848ab5505b0fa5bd650e19e7652c3e1181d3c49f087c50ed055f395eaf5917a99744ed3594e4af9032c4e18f397af58fb1010e695ac2c0bc601b5e3 WHIRLPOOL 63662b56011edb6d22ce28cc7bad3af272ff81862f0d8ff65b113af260e3c8d05a9d941c1cf4b8039b99f460c3a5c8364dd69d42d8e98c0c92530462f732dec2
DIST freetds-1.00.41.tar.gz 2904915 SHA256 f054f1ac09d933527b634e081f5b36856669b7a507601cde93eda32174681e59 SHA512 dec3197a6478fc59b7386f9a7a562df8b581bba7184210c42f26827e957b9746e6820d687a9c6cbcd7c825fc5d4f556547c0483d06c786a064d5c4859db4daa1 WHIRLPOOL de396ba6fa04c7fb580614297c62f61c77a606417e749eb1dd4ad352e7f87cea05ed1567d7dd7f97b189f83d48f711e1254a59d0f9c897050b505e31f6fe8da7
DIST freetds-1.00.53.tar.gz 2906676 SHA256 153c7800f1abf2a6c254e0acbaa618e683e84dbe66f5d156d46d5ce5b280ae32 SHA512 89896a9e02112b99e9d13d55841595e5a20b3c3dd0d5a5fd28cc787669942e8b6361c908536955648e0bd49dcdc829bd1206e228e884fc6a499fa67afa1c3075 WHIRLPOOL 933e6b20abe75759c2c84d2f11f441a4b4f5289359d1948b7a19e455a41bb26df7eb78c12496408096bca380f4a234c121cd76d283f4202c3f4912de1eba06ef
48 changes: 48 additions & 0 deletions dev-db/freetds/files/without-flags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
From c4b9d766e009273c70d8953767ef2fcb95f65314 Mon Sep 17 00:00:00 2001
From: Michael Orlitzky <[email protected]>
Date: Fri, 11 Aug 2017 16:45:15 -0400
Subject: [PATCH] configure.ac: support "without" versions of three ./configure
flags.

The --with-iodbc, --with-unixodbc, and --with-odbc-nodm flags all use
the standard AC_ARG_WITH macro. The resulting ./configure script
accepts e.g. --without-iodbc to indicate that the user does not want
to enable iODBC, and in place of a path the word "no" is placed into
the $with_iodbc variable. The current configure.ac doesn't handle that
and instead treats "no" as a path. This commit updates configure.ac to
ignore "no" as the value of those three flags.
---
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/configure.ac b/configure.ac
index 4f41033ae..9dfe12bb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,7 +546,7 @@ esac

AC_ARG_WITH(iodbc,
AS_HELP_STRING([--with-iodbc=DIR], [build odbc driver against iODBC in DIR]))
-if test "$with_iodbc"; then
+if test "x$with_iodbc" != "x" -a "x$with_iodbc" != "xno"; then
if echo "$with_iodbc" | grep -v '^/'; then
with_iodbc="$PWD/$with_iodbc"
fi
@@ -563,7 +563,7 @@ fi

AC_ARG_WITH(unixodbc,
AS_HELP_STRING([--with-unixodbc=DIR], [build odbc driver against unixODBC in DIR]))
-if test "$with_unixodbc"; then
+if test "x$with_unixodbc" != "x" -a "x$with_unixodbc" != "xno"; then
if echo "$with_unixodbc" | grep -v '^/'; then
with_unixodbc="$PWD/$with_unixodbc"
fi
@@ -588,7 +588,7 @@ fi

AC_ARG_WITH(odbc_nodm,
AS_HELP_STRING([--with-odbc-nodm=DIR], [build odbc using headers in DIR/include]))
-if test "$with_odbc_nodm"; then
+if test "x$with_odbc_nodm" != "x" -a "x$with_odbc_nodm" != "xno"; then
if echo "$with_odbc_nodm" | grep -v '^/'; then
with_odbc_nodm="$PWD/$with_odbc_nodm"
fi
68 changes: 68 additions & 0 deletions dev-db/freetds/freetds-1.00.53.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="Tabular Datastream Library"
HOMEPAGE="http://www.freetds.org/"
SRC_URI="ftp://ftp.freetds.org/pub/freetds/stable/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
IUSE="gnutls iconv kerberos libressl mssql iodbc odbc ssl"
RESTRICT="test"

# sed, grep, and awk are used by the build system and the osql script.
COMMON_DEPEND="sys-apps/sed
sys-apps/grep
virtual/awk
gnutls? ( net-libs/gnutls )
iconv? ( virtual/libiconv )
iodbc? ( dev-db/libiodbc )
kerberos? ( virtual/krb5 )
odbc? ( dev-db/unixODBC )
ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)"

DEPEND="${COMMON_DEPEND}"

# bind-tools is needed because the osql script calls "host".
# binutils is for "strings".
RDEPEND="${COMMON_DEPEND}
sys-devel/binutils
net-dns/bind-tools"

# Won't be necessary in the next release.
PATCHES=( "${FILESDIR}/without-flags.patch" )

src_prepare() {
default

# Fix the iodbc include path in the configure script. Otherwise, it
# can't find isql.h.
sed -ie 's:with_iodbc/include":with_iodbc/include/iodbc":' \
configure.ac \
|| die "failed to fix the iodbc include path in configure.ac"

eautoreconf
}

src_configure() {
local myconf=( --with-tdsver=7.4 )
myconf+=( $(use_with iodbc iodbc "${EPREFIX}/usr") )
myconf+=( $(use_with odbc unixodbc "${EPREFIX}/usr") )
myconf+=( $(use_enable iconv libiconv) )
myconf+=( $(use_with iconv libiconv-prefix "${EPREFIX}/usr") )
myconf+=( $(use_enable kerberos krb5) )
myconf+=( $(use_enable mssql msdblib) )
myconf+=( $(use_with gnutls) )
myconf+=( $(use_with ssl openssl "${EPREFIX}/usr") )
myconf+=( --docdir="/usr/share/doc/${PF}" )

econf "${myconf[@]}"
}

0 comments on commit 42c6544

Please sign in to comment.