forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Parse-RecDescent: Bump to version 1.967.14
Upstream: - Inject PAUSE index preventions in generated parsers. - Avoid "." in @inc test failures Bug: https://bugs.gentoo.org/614614 Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
1 parent
46808e6
commit 42e7267
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Parse-RecDescent-1.967013.tar.gz 176362 SHA256 226590d3850cd1678deb0190d5207b3477fb9070a8ca6f18d8999daf44485930 SHA512 10d3daca3b4d23059937f81fe188b2377598841381dc92582c5cce6a1bfcb5963e1eed4d7f1601a45ae41ed0f3f864a50ff68cd72e05778866fe83cd3d158def WHIRLPOOL 3418d15447f4c898194705616720c38d337a2ccad8c632b78e8460d0b7c66f1065070e81dce81caf72782f7ca0cf1729e779e8cf5755d331088b02766cfb2106 | ||
DIST Parse-RecDescent-1.967014.tar.gz 176884 SHA256 7041c483431fefd08eb66944fb5f8f7fb0fc595c08b33ed2f4c7037b8acccdcd SHA512 bdb369cc8ef47f428d52192271d57baaa88db986f4765ef9262bcb82fda1e619102387ce1828998057adb5607e6def667ba557766af470e2ea2cbe00ee31d16a WHIRLPOOL e2c0b7e4fc280485a9cbdf6596ae423fbf7c5a435f7e0db171fea5ab7708de767fb2cc551ef0f26443d5fdb35524c8a07c2eab521895cfb00638049d04277325 |
39 changes: 39 additions & 0 deletions
39
dev-perl/Parse-RecDescent/Parse-RecDescent-1.967.14.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=JTBRAUN | ||
DIST_VERSION=1.967014 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Generate Recursive-Descent Parsers" | ||
|
||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris" | ||
IUSE="test examples" | ||
|
||
RDEPEND=" | ||
>=virtual/perl-Text-Balanced-1.950.0 | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-perl/Module-Build | ||
test? ( | ||
virtual/perl-Test-Simple | ||
dev-perl/Test-Warn | ||
) | ||
" | ||
src_test() { | ||
perl_rm_files "t/pod.t" | ||
perl-module_src_test | ||
} | ||
src_install() { | ||
perl-module_src_install | ||
docinto html/ | ||
dodoc -r tutorial | ||
if use examples; then | ||
docompress -x /usr/share/doc/${PF}/examples/ | ||
docinto examples/ | ||
dodoc -r demo/* | ||
fi | ||
} |