Skip to content

Commit

Permalink
dev-util/pycharm-community: Version bump.
Browse files Browse the repository at this point in the history
Closes: gentoo#7987
Closes: https://bugs.gentoo.org/653146
Package-Manager: Portage-2.3.27, Repoman-2.3.9
  • Loading branch information
xmw committed Apr 16, 2018
1 parent bbcfa29 commit 4319feb
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pycharm-community/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pycharm-community-2017.3.3.tar.gz 279677180 BLAKE2B 373276332c918a325290e9ca0fa37ac7512025e0c0ee8149c3c08321b0477a0a5263fc24dece443c471f2a96a1b147153b0952466e374acf62389e1c49a1f114 SHA512 d4e9dffa7d2abef825fdbe7ce2665e2d249b18d81f7dab5051a0a2fda7896e5df7cce16e19518225dd23205c346df8fc5c5b3cb39280886004340cba60aeacd4
DIST pycharm-community-2017.3.4.tar.gz 279847033 BLAKE2B 451540aae6434f39a94a664d4aa8747071c9c045793a7d445bf1acf4c0412309448b9e05b01c7e86d5b6915d144cb5175956981597d24064b2a7f934bd043bf3 SHA512 0478ca55a0dbd45b54c3d1af45a6cfdc562f0a863e3fe09922421ed121e22f5182c71fbc05b0e9fe7a8e92b197f6ad473da34b30b867297690d7bd9df5fda730
DIST pycharm-community-2018.1.1.tar.gz 264905980 BLAKE2B d769c1038eb08ce50c93091a435138e30f0b1ff725c59a59e8bcf0c14825b46448856240841f017a24b1c32e501f1282c77716a59ef7841c87fa48d322f16d03 SHA512 c5b9b14b4ef887a242c018f1eab445d756ca96a894f193493c24819e36bc86a734b3a8bf8d540dce5b915a0157fd56acb1f1755bfe0846da218cf3c7f1a2b28b
DIST pycharm-community-2018.1.tar.gz 264891672 BLAKE2B 4fc85276f1e214ac4f03c11593dfa4e9d50bdca043192816c5bd4f768df436c83ec723683315e8b3558a7129542e371c47945e531d977567e8d87f78b412add4 SHA512 41090a3973a19a53440b68625a1dd448e5c92b07813ab8497478867a06d0b847668db2e9bb179caa967fdaac914073a43fa6db5ec371cc17c491f9614a2ce600
53 changes: 53 additions & 0 deletions dev-util/pycharm-community/pycharm-community-2018.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit gnome2-utils readme.gentoo-r1 xdg

DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"

LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND=">=virtual/jre-1.8"

RESTRICT="mirror strip"

QA_PREBUILT="opt/${PN}/bin/fsnotifier
opt/${PN}/bin/fsnotifier64
opt/${PN}/bin/fsnotifier-arm"

MY_PN=${PN/-community/}

src_prepare() {
default

rm -rf jre || die
}

src_install() {
insinto /opt/${PN}
doins -r *

fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}

dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
newicon bin/${MY_PN}.png ${PN}.png
make_desktop_entry ${PN} ${PN} ${PN}

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_icon_cache_update
}

0 comments on commit 4319feb

Please sign in to comment.