Skip to content

Commit

Permalink
sys-libs/ldb: Bump to version 2.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.2, Repoman-2.3.23
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 11, 2020
1 parent 6346087 commit 436d1a3
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/ldb/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ldb-2.0.12.tar.gz 1680114 BLAKE2B 44d7b8f9ff0c1d2adc59378b9da814fb280043c8bbf5ea59920a23448db5abdd53b69c93002e2d621268610ee202377a35676ecf6bd6601d2a2ef9269e71dd6c SHA512 9f26dadee16c50844b28edf03a05ad11067bfb7678cc3e8baf278709a813498a620db3dad463bfe54adb6a44cb5b551cf1224bc30316be5fc8d29ef17295bdd8
DIST ldb-2.1.3.tar.gz 1673208 BLAKE2B 32723fb8cbf404258a1334589e08f1a1b1ee78a6260327e4793d338f73132ae89a5655f77ef4160a0c4b751f5e33e841420c2027034c78d371bf5fd7f3931a37 SHA512 3f5adf5ed6c98cefce56ba47c986c5d59619731def8fa66440957aba1483de19bcfdc4ec5498d34db70753312b1ad47b864020269df924d3d431c8d4d223af10
DIST ldb-2.1.4.tar.gz 1673335 BLAKE2B 581ea127715d82d849f78c11fc66eb278e45f6c9ff9b379d5a3cfaa8c9c424004614a5a9c2120710d23feb1252294e2abd4983158a2a46e5d70180ad3c765dbd SHA512 7e0eecccc973881dde2390568dc71a2ffe7c7ed894daaa9cadf80c221e1b969fd9a8729f3c48a0f611a64b2941c295a2bc7bd8ba869881ba14f75b8bf331167e
DIST ldb-2.2.0.tar.gz 1676551 BLAKE2B 1ad84372b024e1ed680a09d215324027c9a37883204c2e69bb39d28a280cba639a4a46ec12b12d89f291f5505f55849eee880345412c6d95d9b6d6e9c00a4fd9 SHA512 3814078a51d2110eeda291ac859c0027df88475812bd6b5f2ce8f8f50aba9c84faced97c37aa1f45e406783a8df97c60ae778df897bb0e89ba3ac8568acced69
108 changes: 108 additions & 0 deletions sys-libs/ldb/ldb-2.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)"

inherit python-single-r1 waf-utils multilib-minimal eutils

DESCRIPTION="An LDAP-like embedded database"
HOMEPAGE="https://ldb.samba.org"
SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"

LICENSE="LGPL-3"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="doc +ldap +lmdb python test"

RESTRICT="!test? ( test )"

RDEPEND="
!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
dev-libs/popt[${MULTILIB_USEDEP}]
>=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
>=sys-libs/talloc-2.3.1[python?,${MULTILIB_USEDEP}]
>=sys-libs/tdb-1.4.3[python?,${MULTILIB_USEDEP}]
>=sys-libs/tevent-0.10.2[python(+)?,${MULTILIB_USEDEP}]
ldap? ( net-nds/openldap )
lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
"

DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
virtual/pkgconfig
${PYTHON_DEPS}
${RDEPEND}
"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
test? ( python )"

WAF_BINARY="${S}/buildtools/bin/waf"

MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )

PATCHES=(
"${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
"${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
)

pkg_setup() {
python-single-r1_pkg_setup
}

src_prepare() {
default
multilib_copy_sources
}

multilib_src_configure() {
local myconf=(
$(usex ldap '' --disable-ldap)
$(usex lmdb '' --without-ldb-lmdb)
--disable-rpath
--disable-rpath-install --bundled-libraries=NONE
--with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
--builtin-libraries=NONE
)
if ! multilib_is_native_abi; then
myconf+=( --disable-python )
else
use python || myconf+=( --disable-python )
fi
waf-utils_src_configure "${myconf[@]}"
}

multilib_src_compile() {
waf-utils_src_compile
multilib_is_native_abi && use doc && doxygen Doxyfile
}

multilib_src_test() {
if multilib_is_native_abi; then
WAF_MAKE=1 \
PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
waf test || die
fi
}

multilib_src_install() {
waf-utils_src_install

if multilib_is_native_abi && use doc; then
doman apidocs/man/man3/*.3
docinto html
dodoc -r apidocs/html/*
fi
}

pkg_postinst() {
if has_version sys-auth/sssd; then
ewarn "You have sssd installed. It is known to break after ldb upgrades,"
ewarn "so please try to rebuild it before reporting bugs."
ewarn "See https://bugs.gentoo.org/404281"
fi
}

0 comments on commit 436d1a3

Please sign in to comment.