forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Once again, USE="indi -fits" fails to build. Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
commit 04d2414eec38c087b5c53eb3a7af8705aae38b57 | ||
Author: Andreas Sturmlechner <[email protected]> | ||
Date: Thu Mar 23 23:54:00 2017 +0100 | ||
|
||
Qt5Xml is not used | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 09bc76912..35bfcd92c 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -32,9 +32,9 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH}) | ||
set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules" ${CMAKE_MODULE_PATH}) | ||
|
||
if(BUILD_KSTARS_LITE) | ||
- find_package(Qt5 5.7 REQUIRED COMPONENTS Gui Qml Quick QuickControls2 Xml Svg Sql Network Positioning Concurrent) | ||
+ find_package(Qt5 5.7 REQUIRED COMPONENTS Gui Qml Quick QuickControls2 Svg Sql Network Positioning Concurrent) | ||
else() | ||
- find_package(Qt5 5.4 REQUIRED COMPONENTS Gui Qml Quick Xml Sql Svg Network PrintSupport Concurrent) | ||
+ find_package(Qt5 5.4 REQUIRED COMPONENTS Gui Qml Quick Sql Svg Network PrintSupport Concurrent) | ||
endif() | ||
include(ECMInstallIcons) | ||
include(ECMAddAppIcon) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
PYTHON_COMPAT=( python2_7 ) | ||
inherit kde5 python-single-r1 | ||
|
||
DESCRIPTION="Desktop Planetarium" | ||
HOMEPAGE="https://www.kde.org/applications/education/kstars https://edu.kde.org/kstars" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="fits indi raw wcs xplanet" | ||
|
||
REQUIRED_USE="indi? ( fits )" | ||
|
||
# TODO: AstrometryNet requires new package | ||
COMMON_DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep kplotting) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtprintsupport) | ||
$(add_qt_dep qtsql) | ||
$(add_qt_dep qtsvg) | ||
$(add_qt_dep qtwidgets) | ||
sys-libs/zlib | ||
fits? ( sci-libs/cfitsio ) | ||
indi? ( | ||
$(add_frameworks_dep knotifications) | ||
=sci-libs/indilib-1.3* | ||
) | ||
raw? ( media-libs/libraw:= ) | ||
wcs? ( sci-astronomy/wcslib ) | ||
xplanet? ( x11-misc/xplanet ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
$(add_qt_dep qtconcurrent) | ||
dev-cpp/eigen:3 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
${PYTHON_DEPS} | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/${P}-deps.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package fits CFitsio) | ||
$(cmake-utils_use_find_package indi INDI) | ||
$(cmake-utils_use_find_package raw LibRaw) | ||
$(cmake-utils_use_find_package wcs WCSLIB) | ||
$(cmake-utils_use_find_package xplanet Xplanet) | ||
) | ||
|
||
kde5_src_configure | ||
} |