Skip to content

Commit

Permalink
dev-embedded/libftdi: patch out distutils use
Browse files Browse the repository at this point in the history
  • Loading branch information
thesamesam committed Jun 14, 2024
1 parent e84c314 commit 438dbc8
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 0 deletions.
25 changes: 25 additions & 0 deletions dev-embedded/libftdi/files/libftdi-1.5-py312.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
https://bugs.gentoo.org/934224
http://developer.intra2net.com/git/?p=libftdi;a=commit;h=abd19b721f7e9b4d514ed319ece173ebc7b1ea72

From abd19b721f7e9b4d514ed319ece173ebc7b1ea72 Mon Sep 17 00:00:00 2001
From: =?utf8?q?Dan=20Hor=C3=A1k?= <[email protected]>
Date: Mon, 19 Dec 2022 17:40:43 +0100
Subject: [PATCH] python: move from distutils to sysconfig

The distutils module was deprecated in Python 3.10, and will be removed
in 3.12 [1], thus switch to the sysconfig module instead.

[1] https://peps.python.org/pep-0632/
--- a/python/CMakeLists.txt
+++ b/python/CMakeLists.txt
@@ -42,7 +42,7 @@ endif ()

set_target_properties ( ${SWIG_MODULE_ftdi1_REAL_NAME} PROPERTIES NO_SONAME ON )

-execute_process ( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils import sysconfig; print( sysconfig.get_python_lib( plat_specific=True, prefix='${CMAKE_INSTALL_PREFIX}' ) )"
+execute_process ( COMMAND ${PYTHON_EXECUTABLE} -c "import sysconfig; print( sysconfig.get_path( 'platlib', vars={'platbase': '${CMAKE_INSTALL_PREFIX}'} ) )"
OUTPUT_VARIABLE _ABS_PYTHON_MODULE_PATH
OUTPUT_STRIP_TRAILING_WHITESPACE )

--
1.7.1
4 changes: 4 additions & 0 deletions dev-embedded/libftdi/libftdi-1.5-r6.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -46,6 +46,10 @@ BDEPEND="
python? ( >=dev-lang/swig-4.2.0 )
"

PATCHES=(
"${FILESDIR}"/${P}-py312.patch
)

pkg_setup() {
use python && python-single-r1_pkg_setup
}
Expand Down

0 comments on commit 438dbc8

Please sign in to comment.