forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-gfx/wings: Version bump (bug #383239 by Jacek Szafarkiewicz).
Package-Manager: portage-2.3.0_rc1
- Loading branch information
Jeroen Roovers
committed
Jun 11, 2016
1 parent
b2a0d4f
commit 438f44d
Showing
2 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST wings-1.1.1.tar.bz2 1932572 SHA256 1a75a39a1a4586b242558a879d611adf1566b86785750f48ba60d851c2e40d08 SHA512 e60727328c9431738736466444655f54694973e59ad73e60874450845b080bf65c6b784ee0cb06cdff98f3717841dfbeceb5e36a1c55d98f31f280b972b7a2e3 WHIRLPOOL 9868a2ef5571291fa98db5239d767026d3cb0962c417bea77d7555ed2ff3d7fcded2200cad9347f5c0bb39591037fac9096cb7518f8285d2a3597a607c557d5e | ||
DIST wings-1.5.4.tar.bz2 6213585 SHA256 bd04ca1c1237f3a6f29ce3f653015e21142b849b338a3d1ab8633e3c6bcde663 SHA512 fb0cab378703dad4a240f13b96b7522acb4c8466d01bc498e54baf8f4ff1ae497edc08f926889ff669f525ee9c6b787903a47fc78c66f2d9632a5fa45535ac3f WHIRLPOOL 1f0414b05b9b4a29bcc2288c31e68bf3c087b0f093951b4ed9c1f563567b3fa86aca57c595f5d656502d1962dc95902d810228845f284f588b24a1865ef759d4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit eutils multilib | ||
|
||
DESCRIPTION="Wings 3D is an advanced subdivision modeler" | ||
HOMEPAGE="http://www.wings3d.com/" | ||
SRC_URI="mirror://sourceforge/wings/${P}.tar.bz2" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-lang/erlang-17.0[wxwidgets] | ||
>=media-libs/esdl-1.0.1 | ||
dev-libs/cl | ||
media-libs/libsdl[opengl] | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_configure() { | ||
export ERL_PATH="/usr/$(get_libdir)/erlang/lib/" | ||
export ESDL_PATH="${ERL_PATH}/$(best_version media-libs/esdl | cut -d/ -f2)" | ||
echo $ERL_PATH | ||
echo $ESDL_PATH | ||
} | ||
|
||
src_compile() { | ||
# Work around parallel make issues | ||
emake vsn.mk | ||
for subdir in intl_tools src fonts_src e3d icons plugins_src; do | ||
emake ESDL_PATH="${ESDL_PATH}" -C ${subdir} | ||
done | ||
} | ||
|
||
src_install() { | ||
WINGS_PATH=${ERL_PATH}/${P} | ||
dodir ${WINGS_PATH} | ||
|
||
find -name 'Makefile*' -exec rm -f '{}' \; | ||
|
||
insinto ${WINGS_PATH} | ||
doins -r e3d ebin fonts icons plugins psd shaders src textures tools | ||
|
||
dosym ${WINGS_PATH} ${ERL_PATH}/${PN} | ||
dosym ${ESDL_PATH} ${ERL_PATH}/esdl | ||
newbin "${FILESDIR}"/wings.sh wings | ||
dodoc AUTHORS README | ||
} |