forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/geany: Bump to version 1.26
Package-Manager: portage-2.2.24 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Nov 16, 2015
1 parent
93cdf1a
commit 43b3b38
Showing
2 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST geany-1.23.1.tar.bz2 3622524 SHA256 8815b16e59d8679ec359a1a5754fee05e77f7bca53083c939654bfc77d978fad SHA512 e986c35b5fbbc23745d3acda4cddc5de6f273807ffb4da7ff7ea20f108c1f04d763b1207268f06bc45e675d0f0883b309a90dc8e27b8af2f1ec626b557faf015 WHIRLPOOL d777c915738338de7d67578527c63b9da201eefd3322c2118513082b1f109187f6a4900c6ed335e4bd6b2d6472d34ecaff6d1267f43b38827b73026c813e2108 | ||
DIST geany-1.24.1.tar.bz2 3990492 SHA256 7fb505d9b01fe6874890525f837644a6a38c23a372bb068c65ef3673108a8c33 SHA512 89bf627a861dd4c1087f283c71da9ba9c978f00f3106d97a8ee118c5b1134a8dabc0794a06fb85e58e17689e4d38da4814251b62f4109eb99984fa866483d716 WHIRLPOOL c9c7bfac0130a9e88c22136c5caf19c2965a1707f667a29e20d1aedb626f843ff93fc147b6afdcd1108842bc93e9facf19257a3290aa96c09429af93a5bf4aa7 | ||
DIST geany-1.25.tar.bz2 4149876 SHA256 8ee41da28cead8c94d433e616d7ababa81727c63e9196ca6758ade3af14a49ef SHA512 18c98190e387870fd85e8dba7c8033be90594bad038701cc285bfa6a7c3e8bf2817b91330be8d832c18afa3aba17bb3c9c67d86921c5c55be21483b0eb727942 WHIRLPOOL 3f94b5a87b22bc4c45f5f5eccf8d2cb6a1419fe7598e6e2414eb6ea1c08ea7e35bf28b8e1115da3249e58a2136fae7c82ff2f56dbf416a97df3a55b66133ced6 | ||
DIST geany-1.26.tar.bz2 4195686 SHA256 e38530e87c577e1e9806be3b40e08fb9ee321eb1abc6361ddacdad89c825f90d SHA512 eb030832467eaefd13ea98fccf8ad8fdc6c21eb021b6b4c3364d567b36dac86046ca1192ce14008349c822d38776cec79187382bf46acfafc9d413191001aa79 WHIRLPOOL 7dc7871308585831527f98b9e4df78a33fb2b7162291bf9079ad66986a2023b80178c0a9659e4668035eea72fec0bdb706962946b030be6f00b299ba3fc2b8e0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,68 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils fdo-mime gnome2-utils | ||
|
||
LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW" | ||
NOSHORTLANGS="en_GB zh_CN zh_TW" | ||
|
||
DESCRIPTION="GTK+ based fast and lightweight IDE" | ||
HOMEPAGE="http://www.geany.org" | ||
SRC_URI="http://download.geany.org/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2+ HPND" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux" | ||
IUSE="gtk3 +vte" | ||
|
||
RDEPEND=">=dev-libs/glib-2.28:2 | ||
!gtk3? ( | ||
>=x11-libs/gtk+-2.24:2 | ||
vte? ( x11-libs/vte:0 ) | ||
) | ||
gtk3? ( | ||
>=x11-libs/gtk+-3.0:3 | ||
vte? ( x11-libs/vte:2.90 ) | ||
)" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
dev-util/intltool | ||
sys-devel/gettext" | ||
|
||
pkg_setup() { | ||
strip-linguas ${LANGS} | ||
} | ||
|
||
src_prepare() { | ||
# Syntax highlighting for Portage | ||
sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \ | ||
data/filetype_extensions.conf || die | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--disable-dependency-tracking \ | ||
--docdir="/usr/share/doc/${PF}" \ | ||
$(use_enable gtk3) \ | ||
$(use_enable vte) | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" install | ||
rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt} | ||
prune_libtool_files --all | ||
} | ||
|
||
pkg_preinst() { gnome2_icon_savelist; } | ||
|
||
pkg_postinst() { | ||
fdo-mime_desktop_database_update | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
fdo-mime_desktop_database_update | ||
gnome2_icon_cache_update | ||
} |