Skip to content

Commit

Permalink
dev-qt/qtwebengine: fix build with >=bison-3.7
Browse files Browse the repository at this point in the history
Backport commit from Qt upstream [1].

1. https://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=80-based&id=1a53f599

Reported-by: Toralf Förster <[email protected]>
Thanks-to: YOSHIOKA Takuma <[email protected]>
Closes: https://bugs.gentoo.org/734356
Package-Manager: Portage-3.0.3, Repoman-3.0.0
Signed-off-by: Jimi Huotari <[email protected]>
Closes: gentoo#17171
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
Chiitoo authored and a17r committed Aug 19, 2020
1 parent f320a95 commit 43bc7ef
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
54 changes: 54 additions & 0 deletions dev-qt/qtwebengine/files/qtwebengine-5.15.0-bison-3.7-build.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
From 1a53f5995697f5ac6fd501dbdc0ee39c9488ee66 Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <[email protected]>
Date: Fri, 14 Aug 2020 16:38:48 +0200
Subject: Fix bison 3.7
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Do a replace run inspired by newer versions of the script.

Fixes: QTBUG-86018
Change-Id: Ib1dc771e22a662aff0fae842d135ad58fad08bc1
Reviewed-by: Michael Brüning <[email protected]>
---
.../blink/renderer/build/scripts/rule_bison.py | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

diff --git a/chromium/third_party/blink/renderer/build/scripts/rule_bison.py b/chromium/third_party/blink/renderer/build/scripts/rule_bison.py
index f75e25fd23f..7e0767e951a 100755
--- a/src/3rdparty/chromium/third_party/blink/renderer/build/scripts/rule_bison.py
+++ b/src/3rdparty/chromium/third_party/blink/renderer/build/scripts/rule_bison.py
@@ -45,6 +45,19 @@ from utilities import abs

from blinkbuild.name_style_converter import NameStyleConverter

+def modify_file(path, prefix_lines, suffix_lines, replace_list=[]):
+ prefix_lines = map(lambda s: s + '\n', prefix_lines)
+ suffix_lines = map(lambda s: s + '\n', suffix_lines)
+ with open(path, 'r') as f:
+ old_lines = f.readlines()
+ for i in range(len(old_lines)):
+ for src, dest in replace_list:
+ old_lines[i] = old_lines[i].replace(src, dest)
+ new_lines = prefix_lines + old_lines + suffix_lines
+ with open(path, 'w') as f:
+ f.writelines(new_lines)
+
+
assert len(sys.argv) == 4 or len(sys.argv) == 5

inputFile = abs(sys.argv[1])
@@ -115,3 +128,9 @@ print >>outputHFile, '#define %s' % headerGuard
print >>outputHFile, outputHContents
print >>outputHFile, '#endif // %s' % headerGuard
outputHFile.close()
+
+common_replace_list = [(inputRoot + '.hh',
+ inputRoot + '.h')]
+modify_file(
+ outputCpp, [], [],
+ replace_list=common_replace_list)
--
cgit v1.2.1

1 change: 1 addition & 0 deletions dev-qt/qtwebengine/qtwebengine-5.15.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -85,6 +85,7 @@ PATCHES=(
"${FILESDIR}/${P}-disable-fatal-warnings.patch" # bug 695446
"${FILESDIR}/${PN}-5.14.2-icu67.patch" # bug 720054
"${FILESDIR}/${P}-gcc-10.patch" # bug 721876
"${FILESDIR}/${P}-bison-3.7-build.patch" # bug 734356
)

src_prepare() {
Expand Down

0 comments on commit 43bc7ef

Please sign in to comment.