Skip to content

Commit

Permalink
dev-ml/ocurl: bump to 0.9.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/743595
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Oct 20, 2020
1 parent 06e15d5 commit 43e21d9
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/ocurl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ocurl-0.6.1.tgz 101147 BLAKE2B db0ff240e58bc72fbbbbbb661ccc8222bf65db70e85632094c59b3edfeef63e6ff3f2b7df73e8b1662a159b4177c38714ff1a553193dd092e9aae336b90d9f9e SHA512 2c82c9b8e8d6ee26a85add7a2698ab1f61478777f9c7b0b217cacb6491067b619f508b41c22eaa54cf249147d287a77c62a00aef3b19ee6c135426c4559ab7f3
DIST ocurl-0.7.10.tar.gz 108234 BLAKE2B 17b679e331fa266001744522457cc7f4a3656b97b4558fc9e4458c31abd8700fb0f55ce1f9049de7d95a1df41f6543aa36729bc10d9cb688e5e45c50960d5e3d SHA512 7e7adae7d32a39465d578c0e9a0b3b1d4baed76c41428337e9bdc86f7c948297db22c14bc61b58c28d02871a2f3359767e745891690663b63ee1334a839b49c8
DIST ocurl-0.7.9.tar.gz 108242 BLAKE2B 0402757e9e08b115e322ad007d8b294127584ccd5470eeb3e1db667aba96dc269616e8a2782f1850ac4550533a51e49b58cdb82b077a8fd516f5c83e03fc616d SHA512 daa571279570fa1e4ecfa213b717149f6be3922c3c904a22912d04afcf01651702c8324b4b06cbff1fcc023a1f7663e8b1b1e7f14dc377e043ecf2ac09122877
DIST ocurl-0.9.1.tar.gz 111393 BLAKE2B 83ec8f5e2e83b5cc519683556ca97818a092a80f41305394cc04088371c1179f256dee3d8a8e80597837fb156299698450c70ca00f1ec336ace46b02b84bb51e SHA512 f4acb596f213ce57e749c9805225330b532e17718f3b228745b438cd1fe6d89b37e56d401a11c329107729dd0e6bdd4a425d547f9a83dabe32edbf18aca585b5
35 changes: 35 additions & 0 deletions dev-ml/ocurl/ocurl-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit findlib

DESCRIPTION="OCaml interface to the libcurl library"
HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
LICENSE="MIT"
SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"

SLOT="0/${PV}"
IUSE="examples +ocamlopt"

BDEPEND="virtual/pkgconfig"
RDEPEND=">=net-misc/curl-7.9.8
dev-ml/lwt:=
dev-ml/camlp4:=
>=dev-lang/ocaml-3.12:=[ocamlopt?]"
DEPEND="${RDEPEND}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"

src_compile() {
emake -j1 all
}

src_install() {
findlib_src_install
dodoc CHANGES.txt README.md
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}

0 comments on commit 43e21d9

Please sign in to comment.