Skip to content

Commit

Permalink
media-video/avidemux: 2.7.0 version bump
Browse files Browse the repository at this point in the history
Add x11-libs/libva slot operator.

Closes: https://bugs.gentoo.org/549818
Closes: https://bugs.gentoo.org/641636
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
a17r committed Jan 9, 2018
1 parent c253f11 commit 4404a6d
Show file tree
Hide file tree
Showing 4 changed files with 192 additions and 14 deletions.
1 change: 1 addition & 0 deletions media-video/avidemux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST avidemux_2.6.20.tar.gz 20172362 BLAKE2B d458749e470e60b133a177ddf97ee04a665da3f7b2c52e8cc51f907aa5b51d11338ddab9306603b615170b5cf75ec2d3444bd648756bdb724aa442abf7044553 SHA512 d01d0fc24a3004770bd3923c2debc4fa2752eb71df08cfe423746b9c44a2562ca01d82965ed2563b99572a4bed8034b79487199ce330208b51a3b7f87ccf7103
DIST avidemux_2.7.0.tar.gz 21474504 BLAKE2B c6e55a0b5220d6d3746fa06162bf11253145fd28f2f6f744702d5e0342fba85e546a28883eb847139eadd34c94037ebc7d68f5576e7505a85288556468d14b96 SHA512 7c92213d3bd2849dbdb5a1aff2acd6da231fd76c561b756fbf4a1d5a41e9705d609d7a35b6ca6b77ceb3bf5138f861cd24ed16d8fcec4fd713f09a2ff07e9015
2 changes: 1 addition & 1 deletion media-video/avidemux/avidemux-2.6.20-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -91,7 +91,7 @@ src_configure() {
-DAVIDEMUX_SOURCE_DIR='${S}'
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
-DLIBVA="$(usex vaapi)"
-DLibVA="$(usex vaapi)"
-DVDPAU="$(usex vdpau)"
-DXVIDEO="$(usex xv)"
)
Expand Down
173 changes: 173 additions & 0 deletions media-video/avidemux/avidemux-2.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,173 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

if [[ ${PV} == *9999* ]] ; then
MY_P="${P}"
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
inherit git-r3
else
MY_P="${PN}_${PV}"
SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
inherit cmake-utils qmake-utils xdg-utils

DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"

# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
SLOT="2.7"
IUSE="debug nls nvenc opengl qt5 sdl vaapi vdpau xv"

COMMON_DEPEND="
~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?,nvenc?]
nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
opengl? ( virtual/opengl:0 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
vaapi? ( x11-libs/libva:0= )
"
DEPEND="${COMMON_DEPEND}
qt5? ( dev-qt/linguist-tools:5 )
"
RDEPEND="${COMMON_DEPEND}
nls? ( virtual/libintl:0 )
"
PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"

S="${WORKDIR}/${MY_P}"

src_prepare() {
default

processes="buildCli:avidemux/cli"
if use qt5 ; then
processes+=" buildQt4:avidemux/qt4"
fi

for process in ${processes} ; do
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done

# Fix icon name -> avidemux-2.7.png
sed -i -e "/^Icon/ s:${PN}:${PN}-${SLOT}:" ${PN}2.desktop || \
die "Icon name fix failed."

# The desktop file is broken. It uses avidemux2 instead of avidemux3
# so it will actually launch avidemux-2.7 if it is installed.
sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || \
die "Desktop file fix failed."
if use qt5; then
sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt5:' ${PN}2.desktop || \
die "Desktop file fix failed."
fi

# QA warnings: missing trailing ';' and 'Application' is deprecated.
sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || \
die "Desktop file fix failed."

# Now rename the desktop file to not collide with 2.6.
mv ${PN}2.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."

# Remove "Build Option" dialog because it doesn't reflect
# what the GUI can or has been built with. (Bug #463628)
sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
die "Couldn't remove \"Build Option\" dialog."
}

src_configure() {
# Add lax vector typing for PowerPC.
if use ppc || use ppc64 ; then
append-cflags -flax-vector-conversions
fi

# See bug 432322.
use x86 && replace-flags -O0 -O1

# The build relies on an avidemux-core header that uses 'nullptr'
# which is from >=C++11. Let's use the GCC-6 default C++ dialect.
append-cxxflags -std=c++14

local mycmakeargs=(
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
-DLibVA="$(usex vaapi)"
-DVDPAU="$(usex vdpau)"
-DXVIDEO="$(usex xv)"
)

if use qt5 ; then
mycmakeargs+=(
-DENABLE_QT5="$(usex qt5)"
-DLRELEASE_EXECUTABLE="$(qt5_get_bindir)/lrelease"
)
fi

if use debug ; then
mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
fi

for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
done
}

src_compile() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
BUILD_DIR="${build}" cmake-utils_src_compile
done
}

src_test() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
BUILD_DIR="${build}" cmake-utils_src_test
done
}

src_install() {
for process in ${processes} ; do
local build="${WORKDIR}/${P}_build/${process%%:*}"
BUILD_DIR="${build}" cmake-utils_src_install
done

if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
fperms +x /usr/bin/avidemux3_cli
fi

if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
fperms +x /usr/bin/avidemux3_jobs
fi

cd "${S}" || die "Can't enter source folder."
newicon ${PN}_icon.png ${PN}-${SLOT}.png

if [[ -f "${ED}"/usr/bin/avidemux3_qt5 ]] ; then
fperms +x /usr/bin/avidemux3_qt5
fi

if [[ -f "${ED}"/usr/bin/avidemux3_jobs_qt5 ]] ; then
fperms +x /usr/bin/avidemux3_jobs_qt5
fi

if use qt5 ; then
domenu ${PN}-${SLOT}.desktop
fi
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}
30 changes: 17 additions & 13 deletions media-video/avidemux/avidemux-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -19,15 +19,20 @@ HOMEPAGE="http://fixounet.free.fr/avidemux"

# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
SLOT="2.6"
SLOT="2.7"
IUSE="debug nls nvenc opengl qt5 sdl vaapi vdpau xv"

COMMON_DEPEND="
~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?,nvenc?]
nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
opengl? ( virtual/opengl:0 )
qt5? ( dev-qt/qtgui:5 )
vaapi? ( x11-libs/libva:0 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
vaapi? ( x11-libs/libva:0= )
"
DEPEND="${COMMON_DEPEND}
qt5? ( dev-qt/linguist-tools:5 )
Expand All @@ -51,12 +56,12 @@ src_prepare() {
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done

# Fix icon name -> avidemux-2.6.png
sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || \
# Fix icon name -> avidemux-2.7.png
sed -i -e "/^Icon/ s:${PN}:${PN}-${SLOT}:" ${PN}2.desktop || \
die "Icon name fix failed."

# The desktop file is broken. It uses avidemux2 instead of avidemux3
# so it will actually launch avidemux-2.5 if it is installed.
# so it will actually launch avidemux-2.7 if it is installed.
sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || \
die "Desktop file fix failed."
if use qt5; then
Expand All @@ -68,8 +73,8 @@ src_prepare() {
sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || \
die "Desktop file fix failed."

# Now rename the desktop file to not collide with 2.5.
mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
# Now rename the desktop file to not collide with 2.6.
mv ${PN}2.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."

# Remove "Build Option" dialog because it doesn't reflect
# what the GUI can or has been built with. (Bug #463628)
Expand All @@ -87,14 +92,13 @@ src_configure() {
use x86 && replace-flags -O0 -O1

# The build relies on an avidemux-core header that uses 'nullptr'
# which is from >=C++11. Let's use the GCC-6 default C++ dialect.
# which is from >=C++11. Let's use the GCC-6 default C++ dialect.
append-cxxflags -std=c++14

local mycmakeargs=(
-DAVIDEMUX_SOURCE_DIR='${S}'
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
-DLIBVA="$(usex vaapi)"
-DLibVA="$(usex vaapi)"
-DVDPAU="$(usex vdpau)"
-DXVIDEO="$(usex xv)"
)
Expand Down Expand Up @@ -145,7 +149,7 @@ src_install() {
fi

cd "${S}" || die "Can't enter source folder."
newicon ${PN}_icon.png ${PN}-2.6.png
newicon ${PN}_icon.png ${PN}-${SLOT}.png

if [[ -f "${ED}"/usr/bin/avidemux3_qt5 ]] ; then
fperms +x /usr/bin/avidemux3_qt5
Expand All @@ -156,7 +160,7 @@ src_install() {
fi

if use qt5 ; then
domenu ${PN}-2.6.desktop
domenu ${PN}-${SLOT}.desktop
fi
}

Expand Down

0 comments on commit 4404a6d

Please sign in to comment.