forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/asio: bump version to 1.14.0
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Stefan Strogin <[email protected]>
- Loading branch information
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
DESCRIPTION="Asynchronous Network Library" | ||
HOMEPAGE="https://think-async.com" | ||
SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2" | ||
|
||
LICENSE="Boost-1.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
IUSE="doc examples libressl ssl test" | ||
|
||
RDEPEND="dev-libs/boost | ||
ssl? ( | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
)" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
if ! use test; then | ||
# Don't build nor install any examples or unittests | ||
# since we don't have a script to run them | ||
cat > src/Makefile.in <<-EOF || die | ||
all: | ||
install: | ||
clean: | ||
EOF | ||
fi | ||
} | ||
|
||
src_install() { | ||
use doc && local HTML_DOCS=( doc/. ) | ||
default | ||
|
||
if use examples; then | ||
# Get rid of the object files | ||
emake clean | ||
dodoc -r src/examples | ||
docompress -x /usr/share/doc/${PF}/examples | ||
fi | ||
} |