Skip to content

Commit

Permalink
app-misc/mosquitto: Version bump to 1.4.9
Browse files Browse the repository at this point in the history
Proxy commit for Neil Bothwick
Gentoo-Bug: 588502

Package-Manager: portage-2.3.0
  • Loading branch information
mrueg committed Aug 22, 2016
1 parent f08aaca commit 440f689
Show file tree
Hide file tree
Showing 3 changed files with 141 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/mosquitto/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mosquitto-1.4.8.tar.gz 326120 SHA256 d96eb5610e57cc3e273f4527d3f54358ab7711459941a9e64bc4d0a85c2acfda SHA512 4bad8683e98ec858468c53f85f53b42a4166667cebf665d11d3dabe604711f5031da007c8f6d6cb49b8bc91b87eb452bc1f8bfa6adf2d439d2223180b316f9bc WHIRLPOOL b2931c55f3e70316cb57ae180f361c1dedf67e86fec9f235aa3b817884e6af13b8b9b8dc83e375a877d85b1d423ea586ee0698b08af88873a1131d58b4ed402a
DIST mosquitto-1.4.9.tar.gz 325712 SHA256 1df3ae07de40b80a74cd37a7b026895c544cdd3b42c9e0719ae91623aa98c58b SHA512 5994159d9a8da248a877f3032f36ca9a865d9b4efaafac329620864049992a77d414e02252cbbfef89ea2c37dc761b1885a89e19fc8e82b2a42d38f31e761d4d WHIRLPOOL c03a2c8254dce35bb56c243b17ab255e6d4f8210e73d6855d3abff5d3dcf976ca303082d902616ca4b6bf4ea9b2fcc69e52d3ccde7feac41d3ccf5809b157fed
43 changes: 43 additions & 0 deletions app-misc/mosquitto/files/mosquitto-1.4.9-conditional-tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
--- a/test/broker/Makefile 2016-06-02 22:20:22.000000000 +0100
+++ b/test/broker/Makefile 2016-07-08 14:17:33.772666865 +0100
@@ -63,6 +63,7 @@
./05-clean-session-qos1.py

06 :
+ifeq ($(WITH_BRIDGE),yes)
./06-bridge-reconnect-local-out.py
./06-bridge-br2b-disconnect-qos1.py
./06-bridge-br2b-disconnect-qos2.py
@@ -70,6 +71,7 @@
./06-bridge-b2br-disconnect-qos2.py
./06-bridge-fail-persist-resend-qos1.py
./06-bridge-fail-persist-resend-qos2.py
+endif

07 :
./07-will-qos0.py
@@ -87,10 +89,12 @@
./08-ssl-connect-cert-auth-crl.py
./08-ssl-connect-identity.py
./08-ssl-connect-no-identity.py
+ifeq ($(WITH_BRIDGE),yes)
./08-ssl-bridge.py
./08-tls-psk-pub.py
./08-tls-psk-bridge.py
endif
+endif

09 :
./09-plugin-auth-unpwd-success.py
--- a/test/broker/c/Makefile 2016-02-14 14:36:55.000000000 +0000
+++ b/test/broker/c/Makefile 2016-05-05 09:40:31.440608209 +0100
@@ -13,7 +13,9 @@
$(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1

08-tls-psk-bridge.test : 08-tls-psk-bridge.c
+ifeq ($(WITH_BRIDGE),yes)
$(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
+endif


reallyclean : clean
97 changes: 97 additions & 0 deletions app-misc/mosquitto/mosquitto-1.4.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
PYTHON_COMPAT=( python2_7 )

inherit eutils systemd user python-any-r1

DESCRIPTION="An Open Source MQTT v3 Broker"
HOMEPAGE="http://mosquitto.org/"
SRC_URI="http://mosquitto.org/files/source/${P}.tar.gz"
LICENSE="EPL-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bridge examples +persistence +srv ssl tcpd"

RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
srv? ( net-dns/c-ares )"

LIBDIR=$(get_libdir)
QA_PRESTRIPPED="/usr/sbin/mosquitto
/usr/bin/mosquitto_passwd
/usr/bin/mosquitto_sub
/usr/bin/mosquitto_pub
/usr/${LIBDIR}/libmosquittopp.so.1
/usr/${LIBDIR}/libmosquitto.so.1"

pkg_setup() {
enewgroup mosquitto
enewuser mosquitto -1 -1 -1 mosquitto
}

src_prepare() {
epatch "${FILESDIR}/${P}-conditional-tests.patch"
if use persistence; then
sed -i -e "s:^#autosave_interval:autosave_interval:" \
-e "s:^#persistence false$:persistence true:" \
-e "s:^#persistence_file:persistence_file:" \
-e "s:^#persistence_location$:persistence_location /var/lib/mosquitto/:" \
mosquitto.conf || die
fi
python_setup
python_fix_shebang test
}

src_configure() {
makeopts=(
"LIB_SUFFIX=${LIBDIR:3}"
"WITH_BRIDGE=$(usex bridge)"
"WITH_PERSISTENCE=$(usex persistence)"
"WITH_SRV=$(usex srv)"
"WITH_TLS=$(usex ssl)"
"WITH_WRAP=$(usex tcpd)"
)
einfo "${makeopts[@]}"
}

src_compile() {
emake "${makeopts[@]}"
}

src_test() {
emake "${makeopts[@]}" test
}

src_install() {
emake "${makeopts[@]}" DESTDIR="${D}" prefix=/usr install
keepdir /var/lib/mosquitto
fowners mosquitto:mosquitto /var/lib/mosquitto
dodoc readme.md CONTRIBUTING.md ChangeLog.txt
doinitd "${FILESDIR}"/mosquitto
insinto /etc/mosquitto
doins mosquitto.conf
systemd_dounit "${FILESDIR}/mosquitto.service"

if use examples; then
docompress -x "/usr/share/doc/${PF}/examples"
insinto "/usr/share/doc/${PF}/examples"
doins -r examples/*
fi
}

pkg_postinst() {
elog ""
elog "The Python module has been moved out of mosquitto."
elog "See http://mosquitto.org/documentation/python/"
elog ""
elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
elog ""
elog " rc-update add mosquitto default"
elog " or"
elog " systemctl enable mosquitto"
}

0 comments on commit 440f689

Please sign in to comment.