forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
25 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST yappi-0.93.tar.gz 24367 SHA256 09c028fafb31423a46305d3dc55cf30734b66ec4607541d1b561a2ddb17d2081 SHA512 5e187c3502f44a83d2dd91809ba73d1509c3d9300a038a32ef18a128e8ad5582f888844ec9f3237606d09b447e9fa7b12add132aa723dbb1cea61d628f26331d WHIRLPOOL 4cd9a3f2a8f340a4d86d2aa0c08b56cc2531ac20887da587350b080422110331edb506626b43b902e2a5edc00a816e530920442f97f0c2fc18282d1402a4dfb5 | ||
DIST yappi-0.94.tar.gz 25173 SHA256 15cc17dba1252ecaae29ced1e96c216165d93fd3e9ea05dff1f5e5866f16bd59 SHA512 420295f20b395229822a077848514db2138c7630a1cfc6207462e61eab3179e6fbad8b42569ae2557f0fa639fd8863bc876183554511b0dbf3d8664f8072bb28 WHIRLPOOL 2ebafad1489aa3e9d97d7c9bc6b51e9679941c783ea91ba06c82202d8500e69e7f1db2b1078c2becea2d548cbd65fb3b48774d18b1db388e1c80ee9faf311535 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=(python{2_7,3_{3,4,5}}) | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Yet Another Python Profiler" | ||
HOMEPAGE="https://bitbucket.org/sumerc/yappi/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~x86 ~amd64" | ||
IUSE="test" | ||
|
||
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" | ||
DEPEND="${RDEPEND} | ||
test? ( dev-python/nose[${PYTHON_USEDEP}] )" | ||
|
||
python_test() { | ||
esetup.py test | ||
} |