forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/buildbot-waterfall-view: Version bump, fix metdata.xml inden…
…tation Package-Manager: Portage-2.3.6, Repoman-2.3.3
- Loading branch information
Showing
3 changed files
with
60 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST buildbot-waterfall-view-0.9.10.tar.gz 714260 SHA256 c2768391d7eb92e550afe4210e3cba7b69b34a7c9a27d333582f2a04b0f8b030 SHA512 e57a680fb3be7072f1dd6a757787932d9640f1442370048411987d3521f6c600c1f1adedb439ed439cf7928110a6191c8cc4207bf7cd7ebc8e6d1ac5a36f4a1e WHIRLPOOL 95894f7d7b1a52f0312cf1a11f645f5212cd0a18a62ad99f90c804271013ccd4c3f82f7e851d0e02bddef5da9c1ba8af1b2599d424bd95a7f3f29e7f914fe6c3 | ||
DIST buildbot-waterfall-view-0.9.11.tar.gz 713915 SHA256 54e36f8d02be7c046510173f7adb14e3eaeb912e0f41f1b7784e2ac0744799c1 SHA512 aec554156ac6d430f62a090d61896732cca7a0f9ebeaa33c929113f9fcf07c4383d9aae7e544d3dbeb83e7f267327810c10c04ba3ec1f7f9c7192a03b4cd47f6 WHIRLPOOL 5d9003b79c25622048b22ec5ab5a17cf6219ccca964ce8ab14de7052d95af9deee7e8dc9dadbd819b444c3b1562957625cc39a7e684060dcacbd89c3870e3c54 | ||
DIST buildbot-waterfall-view-0.9.4.tar.gz 705483 SHA256 4e8e8d85a77a95fb6ec6e9b0eaa4a774f80cbc6f3a6568f8525d4c90f336b69f SHA512 b619e366b2d276ec956c7f2b814fbea5ad8d626f21d365f586fb93d9ddd8d90c6e3f290a6404b401051e780b228b84f78642f876783c0da6e96549f0e2c9929c WHIRLPOOL f6622afe37931b1525f4234b138d7cd6c296ab92ea00a476eab2b8cd00192972e2b3ca936d54d01b5ed4d93441824d79734b179153614f568a3023ecb308fcfd | ||
DIST buildbot-waterfall-view-0.9.7.tar.gz 705818 SHA256 d6455df447720e367988f043ae381130add96daf80ae45cdf5a0fbcc8aa082e0 SHA512 4f5a068ff03d2ea24eca2344676eecd5558b02127f805b0c88ab0b1bcf353640a6b0bc8756c12d0565a5fdfc8dedff8394b5dc014378200880d469fa26b7263b WHIRLPOOL 2d63af137626018440975cb55e587a94dd9227e0dbc2b62b6726b9bb86e78b183ad656dcb52ec0afecca6b66a0320bc3ac42bb208c4f835343e6e062d00abfdd | ||
DIST buildbot-waterfall-view-0.9.8.tar.gz 705815 SHA256 a8ffe67b5bb8bd5ac15e6cf853cc693c3328fc508ecfa337613fc8f6081c3603 SHA512 82f75f706c97bdedb744f34229c5efefe6f7bb713874f0d99a322233663764b37572b9c9b7a2004c64d7693f6e58625e0c17bacbf743c16ed5fce16d6ad87b2d WHIRLPOOL 87922d9637a8f9b028c1e7495d552b7b2c63a78c5efb313066e6cc212211b6728de105076ad399ea04086948707b7f5f0182fa6c5e471b5cc83cd9b135ab6677 |
52 changes: 52 additions & 0 deletions
52
dev-util/buildbot-waterfall-view/buildbot-waterfall-view-0.9.11.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="5" | ||
PYTHON_REQ_USE="sqlite" | ||
PYTHON_COMPAT=( python2_7 python3_5 ) | ||
|
||
EGIT_REPO_URI="https://github.com/buildbot/buildbot.git" | ||
|
||
[[ ${PV} == *9999 ]] && inherit git-r3 | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Buildbot waterfall-view plugin" | ||
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-waterfall-view" | ||
|
||
MY_PV="${PV/_p/.post}" | ||
MY_P="${PN}-${MY_PV}" | ||
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
KEYWORDS="" | ||
else | ||
KEYWORDS="~amd64" | ||
fi | ||
|
||
IUSE="test" | ||
|
||
RDEPEND=" | ||
~dev-util/buildbot-${PV}[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}] | ||
" | ||
|
||
DEPEND="${RDEPEND} | ||
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}] | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
#[[ ${PV} == *9999 ]] && S=${S}/www/base | ||
|
||
python_test() { | ||
distutils_install_for_testing | ||
|
||
esetup.py test || die "Tests failed under ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,16 +1,17 @@ | ||
<?xml version='1.0' encoding='UTF-8'?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Markos Chandras</name> | ||
</maintainer> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Brian Dolbec</name> | ||
</maintainer> | ||
<longdescription lang="en">The buildbot-waterfall-view plugin is the user interface code used to generate | ||
the web pages used to display information about the builds. | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Markos Chandras</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
The buildbot-waterfall-view plugin is the user interface code used to | ||
generate the web pages used to display information about the builds. | ||
</longdescription> | ||
<upstream> | ||
<maintainer> | ||
|