Skip to content

Commit

Permalink
dev-libs/libuv: Version 1.19.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Jan 19, 2018
1 parent 8d52408 commit 449c53e
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libuv/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST libuv-1.15.0.tar.gz 1158746 BLAKE2B 7ae636fd04419a423ffc6cd1b5f888b136de716
DIST libuv-1.16.1.tar.gz 1165502 BLAKE2B 07f77f0f9f53caf44962c7ca5e107e6c71c7f656ea22c423e2af1ca56b9b6de56f0afd597a490e22f78a2459f8f2eb0b3418411040ef2bbceae7e55cca4710c0 SHA512 e75c735467c5fc1681bee2b4f4ffae63116644309016d0f507b37643697ae8c85b3be7309288b1aca8fa11c6cb1dc1873962d1dc18fa3ed8cb66c8d2514c95e6
DIST libuv-1.17.0.tar.gz 1167930 BLAKE2B 2e38e400d312005f94ad671203b82794f96e5802117fe6577d04951687310a95098ad8d352add67fd356479fa6c63b7b7027f109a77987e7626d3f77a34b19e7 SHA512 274615dd67808a7b7481184aa9c1650f7646ffe714c5304ea123e287eb09cad2a4c677ac06ae68b7d0e70071545954aa6a80414cd7e37c242a2533563094870c
DIST libuv-1.18.0.tar.gz 1167950 BLAKE2B 2c40adbc2c98ffdd3a8a9c30f90eb90e6b0ad16b23935e43d1e19c53238f1a57e422f6f9a3e00374283c4187faa65e13c3e1546ead3ff1fd8e30d98340947078 SHA512 d1ef70b0f060f40cf57b282279d1d63d6dd019b4b811211b2252db32633a80af46290d201b4a4338f84b3efdfe9754a11b29bfa4a7636b06540b1a65e1fd4fbc
DIST libuv-1.19.0.tar.gz 1174555 BLAKE2B 714bcb8fa747d4c4400750333d30fc53c4999f51a9f979433e2feabff66aae8e2008782f07b10eeff8e43fa1d59d1e51cefb5625c112f382d4f02dea504a0b4e SHA512 b9dfe1df09b67dae27a9aa3a3eb8f3ef31aedf9c95c1361034defab21a017e3978a2e2db502847a0c372a34bffe176acd96616096aa692ef2f35cc854ac8e211
47 changes: 47 additions & 0 deletions dev-libs/libuv/libuv-1.19.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools ltprune multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
RESTRICT="test"

DEPEND="sys-devel/libtool
virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
default

echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
> m4/libuv-extra-automake-flags.m4 || die

eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
cc_cv_cflags__g=no
$(use_enable static-libs static)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
mkdir "${BUILD_DIR}"/test || die
cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
default
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files
}

0 comments on commit 449c53e

Please sign in to comment.