Skip to content

Commit

Permalink
dev-python/catkin_pkg: bump to 0.3.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
aballier committed Oct 14, 2017
1 parent c9e9bc8 commit 44be5d0
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/catkin_pkg/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST catkin_pkg-0.3.6-gh.tar.gz 47637 SHA256 b05797352a89986a6c637ef33685a8cd004a8e5138b553f42a82065bc02f808b SHA512 191ed93271c9e592040110c92a572570fa8dec328ae3203dfea9e1fb6a1cb906350c436d3a9416d6826e57a1d59ef42200797d6a5bdc390aa77d352f716e0cc8 WHIRLPOOL 83f73ddaad17b5cfef4945a4d0c900855586877c47962b903e68f821772f4281f7658d82c4adfdf8067889e82f1264d843f1c4f336876ac8afa1bdfe48edeb37
DIST catkin_pkg-0.3.8-gh.tar.gz 48281 SHA256 5d478ca6df90d7360a3ee4ba14771e64bc4692620cf3909eff838d886f190ae3 SHA512 3e20a8ab807158d6fb6a1c32737747db373824eeb085a6af2fc586c08e9445b40f118f56c3765512b5e6cfe25e2f875bea4d408cbe61a994cebbc3fd1342c024 WHIRLPOOL 0921c0df706c692ab79696fa7d703840dd75a0fbe2d6f45337869994be2e50a8eaff4dd43582021ad3d8082d4a541ea74b45f85128819731a04db7c665869be2
46 changes: 46 additions & 0 deletions dev-python/catkin_pkg/catkin_pkg-0.3.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Standalone Python library for the catkin package system"
HOMEPAGE="http://wiki.ros.org/catkin_pkg"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
PATCHES=(
"${FILESDIR}/catkin_prefix.patch"
"${FILESDIR}/argparse.patch"
"${FILESDIR}/ros_packages.patch"
"${FILESDIR}/infinite_loop2.patch"
)

python_test() {
nosetests -s --tests test || die
}

0 comments on commit 44be5d0

Please sign in to comment.