Skip to content

Commit

Permalink
sys-fs/loop-aes: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
alonbl committed Dec 23, 2015
1 parent 042de0c commit 44e2ca3
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/loop-aes/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST loop-AES-v3.7b.tar.bz2 334227 SHA256 b6794ca655c8a0b9ac47814264d96d7dab588493e3d2c09357eaad1e3436d648 SHA512 f673d8ccb9b3072256ff3501785204f1d64af5211eabaf47b5d3dc6c42e3d7ad6a2e4bcddcad76ee903637097a8aa4e1df9e16fff345af2ecd6e105b32bf35d3 WHIRLPOOL 1d4aeda49fbdfb404d8377bb87572a8a2cf18859917188916c00951829b834c9ec475615adf6f587a4bdda63888fdbee8f91ae0161c1ecba755488292a4d72df
DIST loop-AES-v3.7c.tar.bz2 334719 SHA256 2c4eb21afc6e45d99d17e4c26b084d1f1e45c0453da9092a6a95ef918c588173 SHA512 8b260cfe7864973714ddae37ea7231fdefa98ce104f5bee4a1157653a5dd36a89328ee97f3d76d59e1824468f59e46873acd7e5cf9083b73ef0a3b74c24d6bdb WHIRLPOOL 20d07e5f07a158118dcd022f14dff2144c41c51e9add1c747545b7ae8742dd617705e37b03a39262d9b8faed7550a2563f9d827549c487e31e06287b99d36825
DIST loop-AES-v3.7e.tar.bz2 325609 SHA256 c49f660672347d75a8d971e8afd0e8fbc24d1f50034eca99f85cb72097dfb60c SHA512 823ba931e502239bb93b3d5fab2da3f38f79439790c2f6524dfb953215193e6b5015965ecbd892be85a9957812e9ec8569b59cd91197f6ed956d758429b067cf WHIRLPOOL 0990cc7250d37aee2c991ec6822e2fee233689c23f545177ec6e4bee8ca99265391b97111bcb7526d3ccbb5e8719ffbedb9f497c6d85ee4a8fc4c8488dec8f1a
DIST loop-AES-v3.7f.tar.bz2 325690 SHA256 896091fa2d847c86c4372c7aadf5d49aa62a43803b4fce19ec13981bf0895f3c SHA512 43ebc4e48aaadf4290d927dbf3a2098003f165404254a99b1a1f7f83f968ba168365075c2cfab1bf61c1af4c4aec033055888a1bd04059446d0078d31c43d88b WHIRLPOOL f7a5f9850ea6919ea5fe458ccc29a39b4f14a6d10b15075b5b737e3efdc3cd3be48fb58b0f207ff93596eaef5091260791176b77be5cd603d48c5efdeeb6df4a
78 changes: 78 additions & 0 deletions sys-fs/loop-aes/loop-aes-3.7f.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils linux-mod

MY_P="${PN/aes/AES}-v${PV}"

DESCRIPTION="Linux kernel module to encrypt local file systems and disk partitions with AES cipher"
HOMEPAGE="http://loop-aes.sourceforge.net/loop-AES.README"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
IUSE="cpu_flags_x86_aes extra-ciphers keyscrub cpu_flags_x86_padlock"

DEPEND="app-crypt/loop-aes-losetup"
RDEPEND=""

S="${WORKDIR}/${MY_P}"

pkg_setup() {
linux-mod_pkg_setup

CONFIG_CHECK="!BLK_DEV_LOOP"
MODULE_NAMES="loop(block::tmp-d-kbuild)"
BUILD_TARGETS="all"

BUILD_PARAMS=" \
V=1 \
LINUX_SOURCE=\"${KERNEL_DIR}\" \
KBUILD_OUTPUT=\"${KBUILD_OUTPUT}\" \
USE_KBUILD=y MODINST=n RUNDM=n"
use cpu_flags_x86_aes && BUILD_PARAMS="${BUILD_PARAMS} INTELAES=y"
use keyscrub && BUILD_PARAMS="${BUILD_PARAMS} KEYSCRUB=y"
use cpu_flags_x86_padlock && BUILD_PARAMS="${BUILD_PARAMS} PADLOCK=y"

if use extra-ciphers; then
MODULE_NAMES="${MODULE_NAMES}
loop_blowfish(block::tmp-d-kbuild)
loop_serpent(block::tmp-d-kbuild)
loop_twofish(block::tmp-d-kbuild)"
BUILD_PARAMS="${BUILD_PARAMS} EXTRA_CIPHERS=y"
fi
}

src_install() {
linux-mod_src_install

dodoc README
dobin loop-aes-keygen
doman loop-aes-keygen.1
}

pkg_postinst() {
linux-mod_pkg_postinst

einfo
einfo "For more instructions take a look at examples in README at:"
einfo "'${EPREFIX}/usr/share/doc/${PF}'"
einfo
einfo "If you have a newer Intel processor (i5, i7), and you use AES"
einfo "you may want to consider using the aes-ni use flag. It will"
einfo "use your processors native AES instructions giving quite a speed"
einfo "increase."
einfo

ewarn
ewarn "Please consider using loop-aes-losetup package instead of"
ewarn "util-linux[loop-aes], it will enable all loop-aes services"
ewarn "without patching util-linux package"
ewarn
ewarn "In future only loop-aes-losetup will be available in portage"
ewarn
}

0 comments on commit 44e2ca3

Please sign in to comment.