Skip to content

Commit

Permalink
app-eselect/eselect-repository: Bump to v12
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 13, 2022
1 parent 52be65b commit 44f5f56
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-eselect/eselect-repository/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eselect-repository-11.tar.gz 8554 BLAKE2B c7bdd1559c310c492b2c00c7a7cb92d48ad24a69ff4485c1282c67b7dd211360fcda6d96eec2b9e734a1b4745f2a0fe9da1ff20d62bf1174a64b6016097ea634 SHA512 31b0b36122e580a018ca66d112cdddfbfe1568030fb9a20440450c17c759bfb872eb7ef99036a3dae14e8384a8f770354fd4cd362ed594408ae9e8dbbc6dea68
DIST eselect-repository-12.tar.gz 8543 BLAKE2B 14866156ddfefebaea368c4a13413d79e7858520861ee2b699cb09b339f3bb4b8393af7201b4cb7d6a60d2a48d168a053cc4707e2f56a7a2a11cfb5156cfa83f SHA512 3b98b9bd87fe61c7fb4d314e72c8433b11dd80501cfd226d4a4de25ca6d08e7a14a2497a1700ac64d704368bb8e5ea2ec337d0712097e9e10182a3122a59e388
52 changes: 52 additions & 0 deletions app-eselect/eselect-repository/eselect-repository-12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1

DESCRIPTION="Manage repos.conf via eselect"
HOMEPAGE="https://github.com/mgorny/eselect-repository"
SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"
REQUIRED_USE=${PYTHON_REQUIRED_USE}

RDEPEND="${PYTHON_DEPS}
app-admin/eselect
$(python_gen_cond_dep '
dev-python/lxml[${PYTHON_USEDEP}]
')
net-misc/wget"
BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
')
)"

src_compile() {
MAKEARGS=(
PREFIX="${EPREFIX}/usr"
SYSCONFDIR="${EPREFIX}/etc"
SHAREDSTATEDIR="${EPREFIX}/var"
ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
)

emake "${MAKEARGS[@]}"
python_fix_shebang eselect-repo-helper
}

src_test() {
epytest
}

src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
einstalldocs
}

0 comments on commit 44f5f56

Please sign in to comment.