Skip to content

Commit

Permalink
media-gfx/hugin: Fix build with exiv2-0.27
Browse files Browse the repository at this point in the history
Switch to eapi7-ver
Sync 9999 deps with 2018.0.0

Closes: https://bugs.gentoo.org/673730
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Dec 29, 2018
1 parent d8579cd commit 450cbf9
Show file tree
Hide file tree
Showing 3 changed files with 37 additions and 6 deletions.
28 changes: 28 additions & 0 deletions media-gfx/hugin/files/hugin-2018.0.0-exiv2-0.27.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
--- a/src/hugin_base/panodata/Exiv2Helper.cpp
+++ b/src/hugin_base/panodata/Exiv2Helper.cpp
@@ -29,6 +29,7 @@
#include "hugin_math/hugin_math.h"
#include "hugin_utils/utils.h"
#include "exiv2/easyaccess.hpp"
+#include "exiv2/version.hpp"

namespace HuginBase
{
@@ -232,7 +233,7 @@
return false;
};
};
-#if EXIV2_TEST_VERSION(0,23,0)
+#if defined EXIV2_VERSION && EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,23,0)
if (_getExiv2Value(exifData, "Exif.PentaxDng.RedBalance", val1) &&
_getExiv2Value(exifData, "Exif.PentaxDng.BlueBalance", val2))
{
@@ -563,7 +564,7 @@
std::string lensName;
// first we are reading LensModel in Exif section, this is only available
// with EXIF >= 2.3
-#if EXIV2_TEST_VERSION(0,22,0)
+#if defined EXIV2_VERSION && EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,22,0)
//the string "Exif.Photo.LensModel" is only defined in exiv2 0.22.0 and above
if(_getExiv2Value(exifData, "Exif.Photo.LensModel", lensName))
#else
8 changes: 5 additions & 3 deletions media-gfx/hugin/hugin-2018.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit python-single-r1 wxwidgets versionator cmake-utils
inherit python-single-r1 wxwidgets cmake-utils eapi7-ver

DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
Expand Down Expand Up @@ -55,7 +55,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DOCS=( authors.txt README TODO )

S=${WORKDIR}/${PN}-$(get_version_component_range 1-2).0
PATCHES=( "${FILESDIR}/${P}-exiv2-0.27.patch" )

S=${WORKDIR}/${PN}-$(ver_cut 1-2).0

pkg_setup() {
use python && python-single-r1_pkg_setup
Expand Down
7 changes: 4 additions & 3 deletions media-gfx/hugin/hugin-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit mercurial python-single-r1 wxwidgets versionator cmake-utils
inherit mercurial python-single-r1 wxwidgets cmake-utils eapi7-ver

DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
Expand Down Expand Up @@ -36,6 +36,7 @@ CDEPEND="
media-libs/tiff:0
>=media-libs/vigra-1.11.0[openexr]
sci-libs/fftw:3.0=
sci-libs/flann
sys-libs/zlib
virtual/glu
virtual/jpeg:0
Expand All @@ -56,7 +57,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DOCS=( authors.txt README TODO )

S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
S=${WORKDIR}/${PN}-$(ver_cut 1-2).0

pkg_setup() {
use python && python-single-r1_pkg_setup
Expand Down

0 comments on commit 450cbf9

Please sign in to comment.