Skip to content

Commit

Permalink
net-misc/lksctp-tools: Version bump
Browse files Browse the repository at this point in the history
Minor fixes and pkgconf support.

Package-Manager: portage-2.3.0
  • Loading branch information
lu-zero committed Oct 8, 2016
1 parent 545d392 commit 4523bca
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/lksctp-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lksctp-tools-1.0.13.tar.gz 564530 SHA256 7c681868a95afc420f941d2f7dc6bfe07658de109aba6969c407ddf213c2f2a5 SHA512 bdcf06223641ca062fd528ad87efbd3ac2a4e721b691bade528ae6d2ad8eaee5a6c0516eff42c83a3afed812c378f3ce782b93efe8ec830d91280b7419ce17b4 WHIRLPOOL a6d02d4ce9a05d40c28d34437f79da2158684d3cab7b9c2ea0ddac61d2c2464af0eb1931865a80bc889a17ea544a93e2125314d9b53c576cf719a09608ef37d4
DIST lksctp-tools-1.0.16.tar.gz 565446 SHA256 0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26 SHA512 ea771f3ffeef4630638ee9cbdf01723d01b1b0ca2e8f147a2b61b907339bd1a0c5d621a58638a3b700b6ffc41de06c7b9002645254a471e279663b64b313f467 WHIRLPOOL cebff8ede44ce9ca82da14b6d5a622876e0b86805672320364bab9ca5c8fc92197c806a88898fbd06598c9120ec5b044d2fd94e3f1814d2742c743217ef12cee
DIST lksctp-tools-1.0.17.tar.gz 795762 SHA256 1aeb204cdb2befc94d9eb3037d1609c9d1d2cd5379d6dd2c0a8ca9b10533aa15 SHA512 055719130b7dda4da9cf002dcd5f1fb3d8cf75300a99365976e087b2b6971b4ccd357f95b515a44e37874af161f7b7f9b42c60191aff938d18fada5a49aa44c4 WHIRLPOOL 0831eccf424b8a02ded67b4c822713bd45bd07e3026ca5812dd0ed57c0d9b9573eee6f191075aea7a6b8587cf7b0b82c1c9b368edb08473d4967cd42ea69536a
46 changes: 46 additions & 0 deletions net-misc/lksctp-tools/lksctp-tools-1.0.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib flag-o-matic autotools autotools-utils

DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
HOMEPAGE="http://lksctp.sourceforge.net/"
SRC_URI="mirror://sourceforge/lksctp/${P}.tar.gz"

LICENSE="|| ( GPL-2+ LGPL-2.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="kernel_linux static-libs"

# This is only supposed to work with Linux to begin with.
DEPEND=">=sys-kernel/linux-headers-2.6"
RDEPEND=""

REQUIRED_USE="kernel_linux"

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.8-prefix.patch #181602
eautoreconf
}

src_configure() {
append-flags -fno-strict-aliasing

autotools-utils_src_configure
}

DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )

src_install() {
autotools-utils_src_install

dodoc doc/*txt
newdoc src/withsctp/README README.withsctp

# Don't install static library or libtool file, since this is used
# only as preloadable library.
use static-libs && rm "${D}"/usr/$(get_libdir)/${PN}/*.a
}

0 comments on commit 4523bca

Please sign in to comment.