Skip to content

Commit

Permalink
dev-ros/imu_transformer: Fix build without tests. Bug #564654.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Nov 1, 2015
1 parent a95a9ed commit 452c860
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 0 deletions.
23 changes: 23 additions & 0 deletions dev-ros/imu_transformer/files/tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
commit 5524d5687803f720ed8532f103e804c82cbdadb4
Author: Alexis Ballier <[email protected]>
Date: Sun Nov 1 23:50:20 2015 +0100

imu_transformer: Fix build with CATKIN_ENABLE_TESTIING=OFF

https://bugs.gentoo.org/show_bug.cgi?id=564654

diff --git a/imu_transformer/CMakeLists.txt b/imu_transformer/CMakeLists.txt
index 9a498dc..1148f19 100644
--- a/imu_transformer/CMakeLists.txt
+++ b/imu_transformer/CMakeLists.txt
@@ -31,7 +31,9 @@ target_link_libraries(imu_transformer_nodelet ${catkin_LIBRARIES})
add_executable(imu_transformer_node src/imu_transformer_node.cpp)
target_link_libraries(imu_transformer_node ${catkin_LIBRARIES})

-roslaunch_add_file_check(launch)
+if(CATKIN_ENABLE_TESTING)
+ roslaunch_add_file_check(launch)
+endif()

install(TARGETS imu_transformer_node imu_transformer_nodelet
RUNTIME DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
1 change: 1 addition & 0 deletions dev-ros/imu_transformer/imu_transformer-0.2.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -27,3 +27,4 @@ RDEPEND="
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/tests.patch" )

0 comments on commit 452c860

Please sign in to comment.