Skip to content

Commit

Permalink
app-forensics/openscap: bump to 1.2.14
Browse files Browse the repository at this point in the history
Requested-by: Labbe Corentin <[email protected]>

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
Marek Szuba committed Aug 3, 2017
1 parent e02f1e5 commit 4534ee3
Show file tree
Hide file tree
Showing 2 changed files with 139 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-forensics/openscap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST openscap-1.2.13.tar.gz 15874074 SHA256 eeaa37a48b71b0cd455a94f40f01aea0572a846a9ea2722f7f5d2fbbc949ec5c SHA512 393b426f3278ab9438439df9a077b95b29bba66dfc2c799b7b40c2bf3980cf619aa1efc27225785ec780aa75926af6751b10fdb0b8d561c8056bf9a9a087792a WHIRLPOOL c49b039f5f05c333ddc0089d7aa0ee6d617af726ca8fbd68316ff6c6e3302eaff36cc527c71c9383934f4143e3c889817c1b5c0b2d783f4652be7b84045c3304
DIST openscap-1.2.14.tar.gz 15980085 SHA256 99100549029c65cf6ad2425ec7f3b189ffb833ad12012e7086e177768f241f33 SHA512 0e408b2dd58b8b424a27f5c852c6dc8c596fdb201e45cc5f762a1998e00511040762df4e55cdfd93dac4c820c28935acdf3942e96227dfa4f4363d682a2da7da WHIRLPOOL d2c4777f00f5c487b2ce1166fa49d878a2a7da2eadcde92c96c243b5447025151d0751e29dc8ae357af10dca6c57a553d9b8ce48f51c08f6be2b19e1a9b03cba
DIST openscap-1.2.5.tar.gz 14513153 SHA256 7e0c56c108ff3042fd6a6650a808553de15e4dfc7ccc9fcdd6a839de827c47ed SHA512 abeafafeaedd60ca08b52b981f83d458bc972894fc466d7cff29170b578a023f314bd330d7c812d838e09cad567ddc5daafa7e46e4b9a0db76451114d98d17ca WHIRLPOOL 703c6467aa19384f6c50bf0cb465ad2a21c724892e8d7db1f1439992dff939933ff4c48d049bddfddd97599618aee0b27c51596e2f84778707257092273897db
138 changes: 138 additions & 0 deletions app-forensics/openscap/openscap-1.2.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,138 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit bash-completion-r1 eutils multilib python-single-r1

DESCRIPTION="Framework which enables integration with Security Content Automation Protocol"
HOMEPAGE="http://www.open-scap.org/"
SRC_URI="https://github.com/OpenSCAP/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="acl caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
RESTRICT="test"

RDEPEND="!nss? ( dev-libs/libgcrypt:0 )
nss? ( dev-libs/nss )
acl? ( virtual/acl )
caps? ( sys-libs/libcap )
gconf? ( gnome-base/gconf )
ldap? ( net-nds/openldap )
pcre? ( dev-libs/libpcre )
rpm? ( >=app-arch/rpm-4.9 )
sql? ( dev-db/opendbx )
xattr? ( sys-apps/attr )
dev-libs/libpcre
dev-libs/libxml2
dev-libs/libxslt
net-misc/curl
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
perl? ( dev-lang/swig )
python? ( dev-lang/swig )
test? (
app-arch/unzip
dev-perl/XML-XPath
net-misc/ipcalc
sys-apps/grep )"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_prepare() {
# uncoment for debugging test
# sed -i 's,set -e,&;set -x,' tests/API/XCCDF/unittests/test_remediate_simple.sh || die
# sed -i 's,^ bash, LC_ALL=C bash,' tests/probes/process/test_probes_process.sh || die

sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die

#probe runlevel for non-centos/redhat/fedora is not implemented
sed -i 's,.*runlevel_test.*,echo "runlevel test bypassed",' tests/mitre/test_mitre.sh || die
sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die

#According to comment of theses tests, we must modify it. For the moment disable it
sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die

# theses tests are hardcoded for checking hald process...,
# but no good solution for the moment, disabling them with a fake echo
# because encased in a if then
# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
sed -i 's,.*process_test.*,echo "process test bypassed",' tests/mitre/test_mitre.sh || die
sed -i 's,.*process58_test.*,echo "process58 test bypassed",' tests/mitre/test_mitre.sh || die

#This test fail
sed -i 's,.*generate report: xccdf,#&,' tests/API/XCCDF/unittests/all.sh || die

if ! use rpm ; then
sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
sed -i 's,^probe_rpm.*_deps_missing=,&disabled_by_USE_flag,' configure || die
sed -i 's,.*rpm.*,#&,' tests/mitre/test_mitre.sh || die
fi
if ! use selinux ; then
einfo "Disabling SELinux probes"
sed -i 's,.*selinux.*, echo "SELinux test bypassed",' tests/mitre/test_mitre.sh || die
#process58 need selinux
sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
fi
if ! use ldap; then
einfo "Disabling LDAP probes"
sed -i 's,ldap.h,ldapp.h,g' configure || die
fi

epatch_user
}

src_configure() {
python_setup
local myconf
if use debug ; then
myconf+=" --enable-debug"
fi
if use python ; then
myconf+=" --enable-python"
else
myconf+=" --enable-python=no"
fi
if use perl ; then
myconf+=" --enable-perl"
fi
if use nss ; then
myconf+=" --with-crypto=nss3"
else
myconf+=" --with-crypto=gcrypt"
fi
if use sce ; then
myconf+=" --enable-sce"
else
myconf+=" --enable-sce=no"
fi
econf ${myconf}
}

src_compile() {
emake
if use doc ; then
cd docs && doxygen Doxyfile || die
fi
}

src_install() {
emake install DESTDIR="${D}"
prune_libtool_files --all
if use doc ; then
dohtml -r docs/html/.
dodoc -r docs/examples/.
fi
dobashcomp "${D}"/etc/bash_completion.d/oscap
rm -rf "${D}"/etc/bash_completion.d || die
}

0 comments on commit 4534ee3

Please sign in to comment.