Skip to content

Commit

Permalink
dev-java/protobuf-java: Add live ebuild.
Browse files Browse the repository at this point in the history
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <[email protected]>
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed Apr 19, 2019
1 parent 7a97db7 commit 4555f65
Showing 1 changed file with 52 additions and 0 deletions.
52 changes: 52 additions & 0 deletions dev-java/protobuf-java/protobuf-java-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 2008-2019 Arfrever Frehtes Taifersar Arahesis and others
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

if [[ "${PV}" == "9999" ]]; then
inherit git-r3

EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
EGIT_SUBMODULES=()
fi

DESCRIPTION="Google's Protocol Buffers - Java bindings"
HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
if [[ "${PV}" == "9999" ]]; then
SRC_URI=""
else
SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
fi

LICENSE="BSD"
SLOT="0/18"
KEYWORDS=""
IUSE=""

DEPEND="~dev-libs/protobuf-${PV}
>=virtual/jdk-1.7"
RDEPEND=">=virtual/jre-1.7
!<dev-libs/protobuf-3[java(-)]"

S="${WORKDIR}/protobuf-${PV}/java"

if [[ "${PV}" == "9999" ]]; then
EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
fi

src_prepare() {
default
java-pkg-2_src_prepare
}

src_compile() {
"${EPREFIX}/usr/bin/protoc" --java_out=core/src/main/java -I../src ../src/google/protobuf/descriptor.proto || die
JAVA_SRC_DIR="core/src/main/java" JAVA_JAR_FILENAME="protobuf.jar" java-pkg-simple_src_compile
}

src_install() {
JAVA_SRC_DIR="core/src/main/java" JAVA_JAR_FILENAME="protobuf.jar" java-pkg-simple_src_install
}

0 comments on commit 4555f65

Please sign in to comment.