Skip to content

Commit

Permalink
media-libs/vulkan-loader: Version bump to 1.0.54.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mattst88 committed Jul 20, 2017
1 parent f6e8c8a commit 4598962
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/vulkan-loader/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST vulkan-loader-1.0.42.0.tar.gz 3699030 SHA256 305d3070f559a3f5ad332aff285a3e
DIST vulkan-loader-1.0.42.2.tar.gz 3701608 SHA256 bc09a5e667c4a34c0a2969c8169e55bbabf9f57a76166ce43fd6e50c8e249725 SHA512 6f591bcb69edde516cf170936e23a3f19f2f57a22b65d19683c10528ed6559501d3dae29ee1d3e820a81a5cd6e608f5710ba15f7c9bc050ea0eaceef2cf82d37 WHIRLPOOL ab5b1cc3a65414c389ab216aba9bb12018969ec6559cfc381881137aa865d8cc79c06221f903f9a3db001fed75dbaea789bc7b17dacbab545ce8fa78f3e968a7
DIST vulkan-loader-1.0.46.0.tar.gz 3732605 SHA256 439db567f03448f57d7899c4a78986669dc4d930af9699986a85bf2fc3d3acb8 SHA512 dc0728c00e017a2ed0b1e34a500a6335f6dee5dd77c7801d7d450c68c6e8c7cd5dec640be6dec1dea28941d927764a636b82a628e0260ca724163afa4152d8b6 WHIRLPOOL aa2424939b3a6c80909efd1f50d668c83aaf828ef490f13cd02391098e018e8ed33c6949ea47caaa4be0b258ba351447654c814c4bc2aa572e53ca582d7143a0
DIST vulkan-loader-1.0.51.0.tar.gz 3796337 SHA256 20c07764e3f69d0d2158070a24faa6b8c5242af0bf8088ac538281c42c2ca119 SHA512 5d198fc9537c8fa3cbde19fc74f8d47595fabcb52c8db1c626fa157f171ed74ad202e086f7c9e94827c1ab682d03bae58af690c510c6705ca92db0548ee575f6 WHIRLPOOL ab49cc588efa97cb994d4f151c6328be385d6aaf3200547197306788823c7c908d850bbee396a5b201b79960ab1df5d341921c014032649b9b7b03081d8c8149
DIST vulkan-loader-1.0.54.0.tar.gz 3842785 SHA256 f2556963f27309485c4d6bd9acece58d51df6a1b13699cc3a2c8d2579e6a3831 SHA512 f5478e1a7f966a2d09b97a3b47a04b4c9ccd68b88126fefcd6f97bfd0347c5a5bebf52e1cdfccc4863d22dd3b875e04cddf406e3e546eb3dc50d2ef61d85a21f WHIRLPOOL 32591f1e9b0e5d91f82dfd48fc676e51e6d3311d680efbc4e8390a6eeb0ebce82905a01eed9ae764ea432f440c9aeeb888d295366074fd57cc0e15b91ecba4a2
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 3152f2a5056077d3e1061ac61e3ef7888ff96dc7 Mon Sep 17 00:00:00 2001
From: Lenny Komow <[email protected]>
Date: Thu, 20 Jul 2017 16:07:14 -0600
Subject: [PATCH] loader: Remove executable stack from libvulkan.so

Change-Id: Id77d5560479cbbc6f5453a6362c5a20dd721fdd0
---
loader/unknown_ext_chain_gas.asm | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/loader/unknown_ext_chain_gas.asm b/loader/unknown_ext_chain_gas.asm
index e463f45be..798760bd8 100644
--- a/loader/unknown_ext_chain_gas.asm
+++ b/loader/unknown_ext_chain_gas.asm
@@ -108,6 +108,10 @@ vkdev_ext\num:

.endif

+#if defined(__ELF__)
+.section .note.GNU-stack,"",%progbits
+#endif
+
.data

termin_error_string:
55 changes: 55 additions & 0 deletions media-libs/vulkan-loader/vulkan-loader-1.0.54.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5} )

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
inherit git-r3
else
KEYWORDS="~amd64"
SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
fi

inherit python-any-r1 cmake-multilib

DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="wayland X"

RDEPEND=""
DEPEND="${PYTHON_DEPS}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? ( x11-libs/libX11:=[${MULTILIB_USEDEP}] )"

src_prepare() {
default
eapply "${FILESDIR}"/${P}-remove-executable-stack.patch
}

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_TESTS=False
-DBUILD_LAYERS=False
-DBUILD_DEMOS=False
-DBUILD_VKJSON=False
-DBUILD_LOADER=True
-DBUILD_WSI_MIR_SUPPORT=False
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
)
cmake-utils_src_configure
}

multilib_src_install() {
keepdir /etc/vulkan/icd.d

default
}

0 comments on commit 4598962

Please sign in to comment.