Skip to content

Commit

Permalink
dev-haskell/testpack: tweak for QuickCheck-2.8, bug #561010
Browse files Browse the repository at this point in the history
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/561010

Package-Manager: portage-2.2.20
  • Loading branch information
Sergei Trofimovich committed Sep 21, 2015
1 parent fcc8db0 commit 45b650a
Show file tree
Hide file tree
Showing 3 changed files with 15 additions and 1 deletion.
13 changes: 13 additions & 0 deletions dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/src/Test/HUnit/Tools.hs b/src/Test/HUnit/Tools.hs
index a24a510..6b8a25e 100644
--- a/src/Test/HUnit/Tools.hs
+++ b/src/Test/HUnit/Tools.hs
@@ -97,3 +97,7 @@ runVerbTestText (HU.PutText put us) t = do
reportFailure = reportProblem "Failure:" "Failure in: "
- reportProblem p0 p1 msg ss us = put line True us
+ reportProblem p0 p1
+#if MIN_VERSION_HUnit(1,3,0)
+ _loc
+#endif
+ msg ss us = put line True us
where line = "### " ++ kind ++ path' ++ '\n' : msg
2 changes: 1 addition & 1 deletion dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch
Original file line number Diff line number Diff line change
Expand Up @@ -116,7 +116,7 @@ index 712c9bf..506686f 100644
- reason = "Result: expected " ++ show expected ++ ", got " ++ show actual,
- stamp = [], callbacks = []}
-
+ P.result { P.ok = Just (expected == actual)
+ P.failed { P.ok = Just (expected == actual)
+ , P.reason = "Result: expected " ++ show expected ++ ", got " ++ show actual
+ }
{- | Like '@=?', but with args in a different order. -}
Expand Down
1 change: 1 addition & 0 deletions dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,4 +30,5 @@ DEPEND="${RDEPEND}

src_prepare() {
epatch "${FILESDIR}"/${P}-qc28.patch
epatch "${FILESDIR}"/${P}-HUnit-1.3.patch
}

0 comments on commit 45b650a

Please sign in to comment.