Skip to content

Commit

Permalink
sys-fs/dd-rescue: Bump to version 1.99.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Lars Wendler committed Dec 31, 2016
1 parent 9b89d90 commit 45eaabb
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/dd-rescue/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST dd_rescue-1.28.tar.gz 22093 SHA256 4adcc368a1d4ad62577eaf8609809be1678335d54ef565a5a0fa6e1210489f03 SHA512 64a6eb2d6efbe79ca078b8de727ce551acd3a43bc6258b633a4de9ee51933944badc370855c27f05f306d8d3e95332c4b8884f7c11af321a9ac6797f9b02a3a3 WHIRLPOOL 138149efa98d0ade917d10eb6e64bae5cca0e60685eb4e804773e97cd31389f645544a969fd52747aa957260f01fa89db642929a8c36106b915d13eb87715fd4
DIST dd_rescue-1.46.tar.gz 126790 SHA256 9e09b5583f778fe43b6c473998fe0455486d5ffeacbb72b022d6cf5ba8241aba SHA512 efd1bf5d80d4bafa6e6971caa84205dc5df4456a29a9fa3bb56aa984d68675ae3418e8ba3a355906f491f0f2e750c38fd695e37dbd193e554cd41afec3841e28 WHIRLPOOL ac965019d38539962018bcc5a6d32cbf303b4d00d5ed91d643655a820f17bfa1ca81b5123f95220663823e6622d55099a2da08aaacf60cefc37097aa3354c729
DIST dd_rescue-1.99.5.tar.bz2 170712 SHA256 125d327118d1beab24b5858accb2c755dc07ae5b40bb07a985d837c6e3256935 SHA512 a240eb9d50950cefbc65d953c84a8e3782d39282aff4e7fa42364b40cee0eb0a02f61315786a1008cf7ae9c3d758700e9f3a0087b9477b3ffbfcbcef59f07d88 WHIRLPOOL 543a818b748086b1d1163343b02b8e83f7a03713d5394fc0702f48b515cd50b24e30898990439689cbef8270d0b410fdea2dc5b50b8c45728f9ed38c23d414c5
DIST dd_rescue-1.99.tar.bz2 168200 SHA256 5545f54a5e5bee2b9ac69959b1bc81aafae24939393efb8cc581e68ab1b2e47d SHA512 f484f1a86b3bd7c098eb568e193888d98def35b1bec2f553eb3543a5ae22417dbddb562a5c809613a1493ecac3689dcc2a45e26446a3e16036a19e716e38bd11 WHIRLPOOL 94ca6b49636c3f8b0a0901141a3ca16945f0cb5364b97d5d0d759ee1b034f33019ee0bf4f43f7977f0176832d95cecc0aab9cb89e783eabac14290ada4c9f1e1
87 changes: 87 additions & 0 deletions sys-fs/dd-rescue/dd-rescue-1.99.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs flag-o-matic multilib autotools

MY_PN=${PN/-/_}
MY_P=${MY_PN}-${PV}

DESCRIPTION="Similar to dd but can copy from source with errors"
HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="cpu_flags_x86_avx2 lzo cpu_flags_x86_sse4_2 static xattr"

RDEPEND="lzo? ( dev-libs/lzo )
xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}"

S="${WORKDIR}/${MY_P}"

src_prepare() {
epatch "${FILESDIR}/${MY_PN}-1.99-test_fix.patch"
epatch "${FILESDIR}/${MY_PN}-1.99-musl.patch"

sed -i \
-e 's:-ldl:$(LDFLAGS) -ldl:' \
-e 's:-shared:$(CFLAGS) $(LDFLAGS) -shared:' \
Makefile
eautoreconf
}

src_configure() {
use static && append-ldflags -static
# OpenSSL is only used by a random helper tool we don't install.
ac_cv_header_attr_xattr_h=$(usex xattr) \
ac_cv_header_openssl_evp_h=no \
ac_cv_lib_lzo2_lzo1x_1_compress=$(usex lzo) \
econf
}

_emake() {
local arch
case ${ARCH} in
x86) arch=i386;;
amd64) arch=x86_64;;
arm) arch=arm;;
arm64) arch=aarch64;;
esac

local os=$(usex kernel_linux Linux IDK)

# The Makefile is a mess. Override a few vars rather than patch it.
emake \
MACH="${arch}" \
OS="${os}" \
HAVE_SSE42=$(usex cpu_flags_x86_sse4_2 1 0) \
HAVE_AVX2=$(usex cpu_flags_x86_avx2 1 0) \
RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
CFLAGS_OPT='$(CFLAGS)' \
LDFLAGS="${LDFLAGS} -Wl,-rpath,${EPREFIX}/usr/$(get_libdir)/${PN}" \
CC="$(tc-getCC)" \
"$@"
}

src_compile() {
_emake
}

src_test() {
_emake check
}

src_install() {
# easier to install by hand than trying to make sense of the Makefile.
dobin dd_rescue
dodir /usr/$(get_libdir)/${PN}
cp -pPR libddr_*.so "${ED}"/usr/$(get_libdir)/${PN}/ || die
dodoc README.dd_rescue
doman dd_rescue.1
use lzo && doman ddr_lzo.1
}

0 comments on commit 45eaabb

Please sign in to comment.