Skip to content

Commit

Permalink
dev-libs/expat: 2.1.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
hartwork committed Mar 12, 2016
1 parent 0bc75fe commit 4605402
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/expat/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST expat-2.1.0.tar.gz 562616 SHA256 823705472f816df21c8f6aa026dd162b280806838bb55b3432b0fb1fcca7eb86 SHA512 2a9ad2b44b87b84087979fe4114d661838df3b03dbdcb74d590cb74096bf35ce9d5a86617b0941a2655ea441a94537bcbcd78252da92342238823be36de2d09d WHIRLPOOL 147eb383fdb79116e2215982e9741939f80249a0bb690e93b00218fa335d483d88f82d9256632b458b13592252aeb100ec4ef830c72bb8eb5df7675cd15f41e1
DIST expat-2.1.1.tar.bz2 405103 SHA256 aff584e5a2f759dcfc6d48671e9529f6afe1e30b0cd6a4cec200cbe3f793de67 SHA512 088e2ef3434f2affd4fc79fe46f0e9826b9b4c3931ddc780cd18892f1cd1e11365169c6807f45916a56bb6abcc627dcd17a23f970be0bf464f048f5be2713628 WHIRLPOOL d003f427e3e80cd335994190495594d35696205196b1755ff90dcc07fd7cc1c4933f37592e54cdae5420cd91ae326c3b928ef8d5f5cfd84224e1069c51b6a9bb
88 changes: 88 additions & 0 deletions dev-libs/expat/expat-2.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils libtool multilib toolchain-funcs multilib-minimal

DESCRIPTION="Stream-oriented XML parser library"
HOMEPAGE="http://expat.sourceforge.net/"
SRC_URI="mirror://sourceforge/expat/${P}.tar.bz2"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
IUSE="elibc_FreeBSD examples static-libs unicode"
RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r6
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"

multilib_src_configure() {
local myconf="$(use_enable static-libs static)"

mkdir -p "${BUILD_DIR}"{u,w} || die

ECONF_SOURCE="${S}" econf ${myconf}

if use unicode; then
pushd "${BUILD_DIR}"u >/dev/null
CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
popd >/dev/null

pushd "${BUILD_DIR}"w >/dev/null
CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
popd >/dev/null
fi
}

multilib_src_compile() {
emake

if use unicode; then
pushd "${BUILD_DIR}"u >/dev/null
emake buildlib LIBRARY=libexpatu.la
popd >/dev/null

pushd "${BUILD_DIR}"w >/dev/null
emake buildlib LIBRARY=libexpatw.la
popd >/dev/null
fi
}

multilib_src_install() {
emake install DESTDIR="${D}"

if use unicode; then
pushd "${BUILD_DIR}"u >/dev/null
emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
popd >/dev/null

pushd "${BUILD_DIR}"w >/dev/null
emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
popd >/dev/null

pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
cp expat.pc expatu.pc
sed -i -e '/^Libs/s:-lexpat:&u:' expatu.pc || die
cp expat.pc expatw.pc
sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
popd >/dev/null
fi

if multilib_is_native_abi ; then
# libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
# we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
use elibc_FreeBSD && gen_usr_ldscript -a expat
fi
}

multilib_src_install_all() {
dodoc Changes README
dohtml doc/*

if use examples; then
insinto /usr/share/doc/${PF}/examples
doins examples/*.c
fi

prune_libtool_files
}

0 comments on commit 4605402

Please sign in to comment.