Skip to content

Commit

Permalink
dev-ruby/ruby-filemagic: add 0.7.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
graaff committed Oct 28, 2015
1 parent 585d11b commit 4610b84
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/ruby-filemagic/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ruby-filemagic-0.7.0.gem 229376 SHA256 e28af7f49955d800c3dfd1a2335c5c1aa9f380e57eda16050250e4345ad0e460 SHA512 ba257ac7ae58e664d0a45c319c9159650a267144941fdf558f2bd7aa442133f8303637153ab1eb89611c8709303afebbab42f1c3674cca89d15f5037c9bc9d43 WHIRLPOOL 8f64cdea5c7ec028e2d9bf116700e34cda12264946ae847ae5cbd014bd0518368788c6769c49c09775f7cdb3f647a6391cfffc4af29b139be4637a34ad4296eb
DIST ruby-filemagic-0.7.1.gem 229376 SHA256 811de93cdc7d13dbd84d5fd3a35d699092e71a768af366637951ca109cbc7eed SHA512 9a05699fd299c20a52443d4a0213761229fa600157731712c8322e25e18cfc1f467075b8cb5e8c1790caeae9778e83cae83bb1c63475ea220a9b2d9ed896cd46 WHIRLPOOL 82d41b0264f16a2acc402ea297bc6db5ab489bdcc9a50933e916b26bf6103f483220e485ff0b102ed4b33a55898dd874a87be630884b847019d51c12ee208c41
37 changes: 37 additions & 0 deletions dev-ruby/ruby-filemagic/ruby-filemagic-0.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"

RUBY_FAKEGEM_TASK_TEST=""

inherit multilib ruby-fakegem

DESCRIPTION="Ruby binding to libmagic"
HOMEPAGE="https://github.com/blackwinter/ruby-filemagic"

LICENSE="Ruby"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""

DEPEND="${DEPEND} sys-apps/file"
RDEPEND="${RDEPEND} sys-apps/file"

each_ruby_configure() {
${RUBY} -Cext/filemagic extconf.rb || die
}

each_ruby_compile() {
emake V=1 -Cext/filemagic
mv ext/filemagic/ruby_filemagic$(get_modname) lib/filemagic/ || die
}

each_ruby_test() {
${RUBY} -Ctest -I../lib filemagic_test.rb || die
}

0 comments on commit 4610b84

Please sign in to comment.