forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/gentoo-perl-helpers: Bump to version 0.3.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
1 parent
0d719cb
commit 4627c60
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
54 changes: 54 additions & 0 deletions
54
app-admin/gentoo-perl-helpers/gentoo-perl-helpers-0.3.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="Introspection and Upgrade Assistance tools for Gentoo Perl" | ||
HOMEPAGE="https://github.com/gentoo-perl/gentoo-perl-helpers" | ||
SRC_URI=" | ||
https://github.com/gentoo-perl/${PN}/releases/download/${PV}/${P}.tar.xz | ||
mirror://gentoo/${P}.tar.xz | ||
https://dev.gentoo.org/~kentnl/distfiles/${P}.tar.xz | ||
" | ||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="" | ||
|
||
# Assumed System: | ||
# sys-apps/coreutils | ||
# sys-apps/grep | ||
# sys-apps/findutils | ||
# sys-apps/sed | ||
# app-shells/bash | ||
# sys-apps/gawk | ||
# app-arch/tar | ||
|
||
RDEPEND=" | ||
$(: --format support) | ||
>=app-portage/portage-utils-0.60 | ||
sys-apps/portage | ||
" | ||
DEPEND="" | ||
|
||
src_prepare() { | ||
sed -i -e "s^@@LIBDIR@@^${EPREFIX}/usr/lib/gentoo-perl-helpers^g" \ | ||
-e "s^@@LIBEXECDIR@@^${EPREFIX}/usr/libexec/gentoo-perl-helpers^g" \ | ||
"${S}/bin/gentoo-perl" \ | ||
"${S}/lib/core-functions.sh" \ | ||
|| die "Can't patch bin/gentoo-perl" | ||
default | ||
} | ||
src_compile() { :; } | ||
src_install() { | ||
exeinto /usr/bin | ||
doexe "${S}/bin/"* | ||
|
||
exeinto /usr/libexec/gentoo-perl-helpers | ||
doexe "${S}/libexec/"* | ||
|
||
insinto /usr/lib/gentoo-perl-helpers | ||
doins -r "${S}/lib/"* | ||
|
||
dodoc "${S}/README.mkdn" "${S}/Changes" | ||
} |