forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
virtualbox packages: Bump to version 5.1.28 (bug #631332).
Package-Manager: Portage-2.3.10, Repoman-2.3.3
- Loading branch information
Lars Wendler
committed
Oct 2, 2017
1 parent
01eafca
commit 462fbef
Showing
14 changed files
with
1,313 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
35 changes: 35 additions & 0 deletions
35
app-emulation/virtualbox-additions/virtualbox-additions-5.1.28.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils | ||
|
||
MY_PN=VBoxGuestAdditions | ||
MY_PV="${PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
MY_P=${MY_PN}_${MY_PV} | ||
|
||
DESCRIPTION="CD image containing guest additions for VirtualBox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.iso" | ||
|
||
LICENSE="GPL-2+ LGPL-2.1+ MIT SGI-B-2.0 CDDL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror" | ||
|
||
RDEPEND="!app-emulation/virtualbox-bin | ||
!=app-emulation/virtualbox-9999" | ||
|
||
S="${WORKDIR}" | ||
|
||
src_unpack() { | ||
return 0 | ||
} | ||
|
||
src_install() { | ||
insinto /usr/share/${PN/-additions} | ||
newins "${DISTDIR}"/${MY_P}.iso ${MY_PN}.iso | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
287 changes: 287 additions & 0 deletions
287
app-emulation/virtualbox-bin/virtualbox-bin-5.1.28.117968.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,287 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit eutils fdo-mime gnome2 pax-utils python-r1 udev unpacker versionator | ||
|
||
MAIN_PV="$(get_version_component_range 1-3)" | ||
if [[ ${PV} = *_beta* ]] || [[ ${PV} = *_rc* ]] ; then | ||
MY_PV="${MAIN_PV}_$(get_version_component_range 5)" | ||
MY_PV="${MY_PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
else | ||
MY_PV="${MAIN_PV}" | ||
fi | ||
VBOX_BUILD_ID="$(get_version_component_range 4)" | ||
VBOX_PV="${MY_PV}-${VBOX_BUILD_ID}" | ||
MY_P="VirtualBox-${VBOX_PV}-Linux" | ||
# needed as sometimes the extpack gets another build ID | ||
EXTP_PV="${VBOX_PV}" | ||
EXTP_PN="Oracle_VM_VirtualBox_Extension_Pack" | ||
EXTP_P="${EXTP_PN}-${EXTP_PV}" | ||
# needed as sometimes the SDK gets another build ID | ||
SDK_PV="${VBOX_PV}" | ||
SDK_P="VirtualBoxSDK-${SDK_PV}" | ||
|
||
DESCRIPTION="Family of powerful x86 virtualization products for enterprise and home use" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="amd64? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}_amd64.run ) | ||
x86? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}_x86.run ) | ||
http://download.virtualbox.org/virtualbox/${MY_PV}/${EXTP_P}.vbox-extpack -> ${EXTP_P}.tar.gz" | ||
|
||
LICENSE="GPL-2 PUEL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+additions +chm headless python vboxwebsrv rdesktop-vrdp" | ||
RESTRICT="mirror" | ||
|
||
if [[ "${PV}" != *beta* ]] ; then | ||
SRC_URI+=" | ||
sdk? ( http://download.virtualbox.org/virtualbox/${MY_PV}/${SDK_P}.zip )" | ||
IUSE+=" sdk" | ||
fi | ||
|
||
DEPEND="app-arch/unzip | ||
${PYTHON_DEPS}" | ||
|
||
RDEPEND="!!app-emulation/virtualbox | ||
!app-emulation/virtualbox-additions | ||
~app-emulation/virtualbox-modules-${MAIN_PV} | ||
!headless? ( | ||
dev-libs/glib | ||
media-libs/fontconfig | ||
media-libs/freetype | ||
media-libs/libpng | ||
media-libs/libsdl[X] | ||
x11-libs/libXcursor | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXft | ||
x11-libs/libXi | ||
x11-libs/libXinerama | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
chm? ( dev-libs/expat ) | ||
) | ||
dev-libs/libxml2 | ||
sys-fs/lvm2 | ||
x11-libs/libXau | ||
x11-libs/libX11 | ||
x11-libs/libXt | ||
x11-libs/libXmu | ||
x11-libs/libSM | ||
x11-libs/libICE | ||
x11-libs/libXdmcp | ||
${PYTHON_DEPS}" | ||
|
||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
S=${WORKDIR} | ||
|
||
QA_PREBUILT="opt/VirtualBox/*" | ||
|
||
PYTHON_UPDATER_IGNORE="1" | ||
|
||
src_unpack() { | ||
unpack_makeself ${MY_P}_${ARCH}.run | ||
unpack ./VirtualBox.tar.bz2 | ||
|
||
mkdir "${S}"/${EXTP_PN} || die | ||
pushd "${S}"/${EXTP_PN} &>/dev/null || die | ||
unpack ${EXTP_P}.tar.gz | ||
popd &>/dev/null || die | ||
|
||
if [[ "${PV}" != *beta* ]] && use sdk ; then | ||
unpack VirtualBoxSDK-${SDK_PV}.zip | ||
fi | ||
} | ||
|
||
src_configure() { | ||
:; | ||
} | ||
|
||
src_compile() { | ||
:; | ||
} | ||
|
||
src_install() { | ||
# create virtualbox configurations files | ||
insinto /etc/vbox | ||
newins "${FILESDIR}/${PN}-config" vbox.cfg | ||
|
||
if ! use headless ; then | ||
newmenu "${FILESDIR}"/${PN}.desktop-2 ${PN}.desktop | ||
|
||
# set up symlinks (bug #572012) | ||
dosym ../../../../opt/VirtualBox/virtualbox.xml /usr/share/mime/packages/virtualbox.xml | ||
|
||
local size ico icofile | ||
for size in 16 24 32 48 64 72 96 128 256 ; do | ||
pushd "${S}"/icons/${size}x${size} &>/dev/null || die | ||
if [[ -f "virtualbox.png" ]] ; then | ||
doicon -s ${size} virtualbox.png | ||
fi | ||
for ico in hdd ova ovf vbox{,-extpack} vdi vdh vmdk ; do | ||
icofile="virtualbox-${ico}.png" | ||
if [[ -f "${icofile}" ]] ; then | ||
doicon -s ${size} ${icofile} | ||
fi | ||
done | ||
popd &>/dev/null || die | ||
done | ||
doicon -s scalable "${S}"/icons/scalable/virtualbox.svg | ||
insinto /usr/share/pixmaps | ||
newins "${S}"/icons/48x48/virtualbox.png ${PN}.png | ||
fi | ||
|
||
pushd "${S}"/${EXTP_PN} &>/dev/null || die | ||
insinto /opt/VirtualBox/ExtensionPacks/${EXTP_PN} | ||
doins -r linux.${ARCH} | ||
doins ExtPack* PXE-Intel.rom | ||
popd &>/dev/null || die | ||
rm -rf "${S}"/${EXTP_PN} | ||
|
||
insinto /opt/VirtualBox | ||
dodir /opt/bin | ||
|
||
doins UserManual.pdf | ||
|
||
if [[ "${PV}" != *beta* ]] && use sdk ; then | ||
doins -r sdk | ||
fi | ||
|
||
if use additions; then | ||
doins -r additions | ||
fi | ||
|
||
if use vboxwebsrv; then | ||
doins vboxwebsrv | ||
fowners root:vboxusers /opt/VirtualBox/vboxwebsrv | ||
fperms 0750 /opt/VirtualBox/vboxwebsrv | ||
dosym ../../opt/VirtualBox/VBox.sh /opt/bin/vboxwebsrv | ||
newinitd "${FILESDIR}"/vboxwebsrv-initd vboxwebsrv | ||
newconfd "${FILESDIR}"/vboxwebsrv-confd vboxwebsrv | ||
fi | ||
|
||
if use rdesktop-vrdp; then | ||
doins rdesktop-vrdp | ||
doins -r rdesktop-vrdp-keymaps | ||
fperms 0750 /opt/VirtualBox/rdesktop-vrdp | ||
dosym ../../opt/VirtualBox/rdesktop-vrdp /opt/bin/rdesktop-vrdp | ||
fi | ||
|
||
if ! use headless && use chm; then | ||
doins kchmviewer VirtualBox.chm | ||
fowners root:vboxusers /opt/VirtualBox/kchmviewer | ||
fperms 0750 /opt/VirtualBox/kchmviewer | ||
fi | ||
|
||
# This ebuild / package supports only py2.7. When py3 comes is unknown. | ||
# The compile phase makes VBoxPython2_7.so. | ||
# py3 support would presumably require a binary pre-compiled by py3. | ||
use python && doins VBoxPython.so VBoxPython2_7.so | ||
|
||
rm -rf src rdesktop* deffiles install* routines.sh runlevel.sh \ | ||
vboxdrv.sh VBox.sh VBox.png vboxnet.sh additions VirtualBox.desktop \ | ||
VirtualBox.tar.bz2 LICENSE VBoxSysInfo.sh rdesktop* vboxwebsrv \ | ||
webtest kchmviewer VirtualBox.chm vbox-create-usb-node.sh \ | ||
90-vbox-usb.fdi uninstall.sh vboxshell.py vboxdrv-pardus.py \ | ||
VBoxPython?_*.so | ||
|
||
if use headless ; then | ||
rm -rf VBoxSDL VirtualBox VBoxKeyboard.so | ||
fi | ||
|
||
doins -r * || die | ||
|
||
# create symlinks for working around unsupported $ORIGIN/.. in VBoxC.so (setuid) | ||
dosym ../VBoxVMM.so /opt/VirtualBox/components/VBoxVMM.so | ||
dosym ../VBoxREM.so /opt/VirtualBox/components/VBoxREM.so | ||
dosym ../VBoxRT.so /opt/VirtualBox/components/VBoxRT.so | ||
dosym ../VBoxDDU.so /opt/VirtualBox/components/VBoxDDU.so | ||
dosym ../VBoxXPCOM.so /opt/VirtualBox/components/VBoxXPCOM.so | ||
|
||
local each | ||
for each in VBox{Manage,SVC,XPCOMIPCD,Tunctl,NetAdpCtl,NetDHCP,NetNAT,TestOGL,ExtPackHelperApp}; do | ||
fowners root:vboxusers /opt/VirtualBox/${each} | ||
fperms 0750 /opt/VirtualBox/${each} | ||
pax-mark -m "${D}"/opt/VirtualBox/${each} | ||
done | ||
# VBoxNetAdpCtl and VBoxNetDHCP binaries need to be suid root in any case.. | ||
fperms 4750 /opt/VirtualBox/VBoxNetAdpCtl | ||
fperms 4750 /opt/VirtualBox/VBoxNetDHCP | ||
fperms 4750 /opt/VirtualBox/VBoxNetNAT | ||
|
||
if ! use headless ; then | ||
# Hardened build: Mark selected binaries set-user-ID-on-execution | ||
for each in VBox{SDL,Headless} VirtualBox; do | ||
fowners root:vboxusers /opt/VirtualBox/${each} | ||
fperms 4510 /opt/VirtualBox/${each} | ||
pax-mark -m "${D}"/opt/VirtualBox/${each} | ||
done | ||
|
||
dosym ../VirtualBox/VBox.sh /opt/bin/VirtualBox | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxSDL | ||
else | ||
# Hardened build: Mark selected binaries set-user-ID-on-execution | ||
fowners root:vboxusers /opt/VirtualBox/VBoxHeadless | ||
fperms 4510 /opt/VirtualBox/VBoxHeadless | ||
pax-mark -m "${D}"/opt/VirtualBox/VBoxHeadless | ||
fi | ||
|
||
exeinto /opt/VirtualBox | ||
newexe "${FILESDIR}/${PN}-3-wrapper" "VBox.sh" | ||
fowners root:vboxusers /opt/VirtualBox/VBox.sh | ||
fperms 0750 /opt/VirtualBox/VBox.sh | ||
|
||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxManage | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxVRDP | ||
dosym ../VirtualBox/VBox.sh /opt/bin/VBoxHeadless | ||
dosym ../VirtualBox/VBoxTunctl /opt/bin/VBoxTunctl | ||
|
||
# set an env-variable for 3rd party tools | ||
echo -n "VBOX_APP_HOME=/opt/VirtualBox" > "${T}/90virtualbox" | ||
doenvd "${T}/90virtualbox" | ||
|
||
local udevdir="$(get_udevdir)" | ||
insinto ${udevdir}/rules.d | ||
doins "${FILESDIR}"/10-virtualbox.rules | ||
sed "s@%UDEVDIR%@${udevdir}@" \ | ||
-i "${D}"${udevdir}/rules.d/10-virtualbox.rules || die | ||
# move udev scripts into ${udevdir} (bug #372491) | ||
mv "${D}"/opt/VirtualBox/VBoxCreateUSBNode.sh "${D}"${udevdir} || die | ||
fperms 0750 ${udevdir}/VBoxCreateUSBNode.sh | ||
} | ||
|
||
pkg_postinst() { | ||
fdo-mime_desktop_database_update | ||
|
||
gnome2_icon_cache_update | ||
|
||
udevadm control --reload-rules && udevadm trigger --subsystem-match=usb | ||
|
||
elog "" | ||
if ! use headless ; then | ||
elog "To launch VirtualBox just type: \"VirtualBox\"" | ||
elog "" | ||
fi | ||
elog "You must be in the vboxusers group to use VirtualBox." | ||
elog "" | ||
elog "For advanced networking setups you should emerge:" | ||
elog "net-misc/bridge-utils and sys-apps/usermode-utilities" | ||
elog "" | ||
elog "Please visit http://www.virtualbox.org/wiki/Editions for" | ||
elog "an overview about the different features of ${PN}" | ||
elog "and virtualbox-ose" | ||
if [ -e "${ROOT}/etc/udev/rules.d/10-virtualbox.rules" ] ; then | ||
elog "" | ||
elog "Please remove \"${ROOT}/etc/udev/rules.d/10-virtualbox.rules\"" | ||
elog "or else USB in ${PN} won't work." | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
fdo-mime_desktop_database_update | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.0.40-115130.tar.gz 19050961 SHA256 ebb29de8962d60760a2f25c318833a1fe163368b824b6b26802b6b284af70585 SHA512 fb27a8efa376b2a51558e0a8dfcb87a7116e950783030c1aab996675c776c46cdf4d4ff35d111f925f6b2b4c6fd070ff80a971fd2f6ce77b857b17898950f5a3 WHIRLPOOL db1ba8492abf791f2244d12b7a62643c02c8c7999c607464e117cc42360c876d9ee83d36ea8860e18912b52171d12291d93fdcc3d3ff18ff05c2b3a4cea5373c | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.24-117012.tar.gz 19624088 SHA256 65198a2e048d30fc7d18cd4670fb84fed9a878cca1b77f416b4fea4efe8ca2a4 SHA512 fc821a446c67c4046dd2aa2078d6a71a63a490d59c96f76b29a5a46b26ad7e51588c1009efbafa448e73c799dc816de0b5f0ee17b10d306d3e701a15f69c595d WHIRLPOOL b86d40a08774cd56f612e4bd1edd1bea0e070185e9fab19ca21c0a08ffe092c73877a62dfa5be68e7a963145a84785330c935dd43b5c9ddcfbfc3ee2236f9e0a | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.26-117224.tar.gz 19624237 SHA256 14f152228495a715f526eb74134d43c960919cc534d2bc67cfe34a63e6cf7721 SHA512 c6e31e8fb26b8ca32c423d14e85e15f6372a030ec40e9f06ce1e1234913d3586cc58d46819684c99cf3ced37f35d0a964339199cad5cf43580c88bf1afa63ef6 WHIRLPOOL 9b0ceb8ab21ce54a199ac312879ae4bf17b5bbf3bae6d28035436ae8dd8295ea6fa1d8bb3fc095867a017fdcc357b630436dca46d4875bcdd2aad1ce0cfd9d9f | ||
DIST Oracle_VM_VirtualBox_Extension_Pack-5.1.28-117968.tar.gz 19626161 SHA256 1a2551b204bd53a252a75a4653b983427bb15d473bc77b14149c7870ce049871 SHA512 71c6ce267c14303bbd9e386ea849d37aeb569afff848054deced4c74fd6fffca83c96b392d066f684b7101a786cc7d24cf9308114c08cbb77b26bb07bf23fcf8 WHIRLPOOL c6fd42f422dca4db4165ff18da0054aff5c0d275850dec4002fb70e8e4248f8f5cffc87697b0802343ebff29cf62938f298df365f9ce19523092d418206deff9 |
Oops, something went wrong.