Skip to content

Commit

Permalink
dev-util/rosdep: initial import. ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
aballier committed Sep 17, 2015
1 parent 46e2e14 commit 4641980
Show file tree
Hide file tree
Showing 4 changed files with 128 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/rosdep/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST rosdep-0.11.2.tar.gz 106456 SHA256 89da05bdc082005815a9679dc34509a16647374d746a9e636c4238dd8f7aed9e SHA512 55057bb478dce1a7be3025d52fa6fb616b2de95017981ead934d7965282fa6ceb81780b7825d914531f87af492f3b5ce91ecf2607e6bddb65e13744e8a8d6743 WHIRLPOOL 37407d99d58f62c00a54b94a5820cab599c7700be355132e5d7b9d277faa220f89d68c9950cd386e984c64a1f0c493d53db15b31082f485d4786aff232f73d34
5 changes: 5 additions & 0 deletions dev-util/rosdep/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ros</herd>
</pkgmetadata>
61 changes: 61 additions & 0 deletions dev-util/rosdep/rosdep-0.11.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Command-line tool for installing ROS system dependencies"
HOMEPAGE="http://wiki.ros.org/rosdep"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
http://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/rosdistro[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"

python_test() {
nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
}

pkg_postrm() {
if [ "${ROOT:-/}" = "/" ] ; then
einfo "Removing rosdep default sources list."
rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
fi
}

pkg_postinst() {
if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
einfo "Initializing rosdep"
rosdep init
fi
}
61 changes: 61 additions & 0 deletions dev-util/rosdep/rosdep-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Command-line tool for installing ROS system dependencies"
HOMEPAGE="http://wiki.ros.org/rosdep"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
http://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/rosdistro[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"

python_test() {
nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
}

pkg_postrm() {
if [ "${ROOT:-/}" = "/" ] ; then
einfo "Removing rosdep default sources list."
rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
fi
}

pkg_postinst() {
if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
einfo "Initializing rosdep"
rosdep init
fi
}

0 comments on commit 4641980

Please sign in to comment.